diff mbox series

[bug#51314] Test patches on Prusa i3 MK3S

Message ID 5_5GHNgyvUcPrdL8o3K8rxI9_ikPpr1lElc6I5j1DgW7ccksAR56TmMvWCHjsH1uP78_zh7ES30f0jRXmw-JxWO9EoSOOSCn70dyp9SKxjE=@protonmail.com
State New
Headers show
Series [bug#51314] Test patches on Prusa i3 MK3S | expand

Commit Message

phodina Dec. 10, 2022, 12:24 p.m. UTC
Hi,

I've also been working on getting the Octoprint printer support into Guix. Since you've already reviewed the patches I used yours.

I had to rebase them on the lastest core-updates (6454208222d6e7760daa964b590f35ea75ffe0e5).

Unfortunately, some issues arise - there are several packages that don't pass tests: python-pytest-localserver, disable python-django, python-tornado-6, python-sgmllib3k, python-feedparser.

I just disabled the tests since I wanted to know if Octoprint works. And it does as shown on the screenshot.

----
Petr

Comments

phodina Dec. 25, 2022, 5:57 p.m. UTC | #1
Hi Maxime,

any thoughts on the failing tests and the rebased patches?

Also is possible that the tests on core-updates can be broken or is some sort of issue on my local machine?

Running: guix shell --pure --check -D guix​

----
Petr

------- Original Message -------
On Saturday, December 10th, 2022 at 1:24 PM, phodina <phodina@protonmail.com> wrote:

> Hi,
>
> I've also been working on getting the Octoprint printer support into Guix. Since you've already reviewed the patches I used yours.
>
> I had to rebase them on the lastest core-updates (6454208222d6e7760daa964b590f35ea75ffe0e5).
>
> Unfortunately, some issues arise - there are several packages that don't pass tests: python-pytest-localserver, disable python-django, python-tornado-6, python-sgmllib3k, python-feedparser.
>
> I just disabled the tests since I wanted to know if Octoprint works. And it does as shown on the screenshot.
>
> ----
> Petr
M Dec. 26, 2022, 12:10 p.m. UTC | #2
On 25-12-2022 18:57, phodina wrote:
> Hi Maxime,
> 
> any thoughts on the failing tests and the rebased patches?
> 
> Also is possible that the tests on core-updates can be broken or is some 
> sort of issue on my local machine?
> 
> Running: |guix shell --pure --check -D guix|​


Hi,

I'm currently taking a break from Guix.

Greetings,
Maxime.
phodina Dec. 26, 2022, 12:36 p.m. UTC | #3
Hi Ivan and Guillaume,

I say your commits for prusa-slicer. Do you use also Octoprint to manage the 3d printer remotely?

If so could I ask you to have a look at the patch set?

----
Petr
diff mbox series

Patch

From 2c2165cfb53025e1eee1e949b9a27dd1888ab3f8 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Fri, 9 Dec 2022 18:25:59 +0100
Subject: [PATCH 13/19] gnu: Add octoprint-pisupport.

* gnu/packages/printers.scm (octoprint-pisupport): New variable.

diff --git a/gnu/packages/printers.scm b/gnu/packages/printers.scm
index e7761070e0..10bd86c1af 100644
--- a/gnu/packages/printers.scm
+++ b/gnu/packages/printers.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2022 Vinicius Monego <monego@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19,8 +20,10 @@ 
 
 (define-module (gnu packages printers)
   #:use-module (guix packages)
+  #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages pkg-config)
@@ -29,6 +32,29 @@  (define-module (gnu packages printers)
 ;; This is a module for packages related to printer-like devices, but not
 ;; related to CUPS.
 
+(define-public octoprint-pisupport
+  (package
+    (name "octoprint-pisupport")
+    (version "2022.3.28")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "OctoPrint-PiSupport" version))
+       (sha256
+        (base32 "11yzcyyia9dyiw428kjwysybxxh93dbc0sl7p59kda84iqwj1m5z"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'sanity-check))))      ; checks for Octoprint
+    (home-page "https://github.com/OctoPrint/OctoPrint-PiSupport")
+    (synopsis "Plugin to provide additional information about your Pi")
+    (description "The Pi Support plugin provides additional information about
+your Pi in the UI and also alerts you about undervoltage or overheating issues
+observed on your Pi or if your Pi is unsupported.")
+    (license license:agpl3)))
+
 (define-public robocut
   (package
     (name "robocut")
-- 
2.38.1