diff mbox series

[bug#53370] Add Blur My Shell

Message ID 5QqXXWIe81KHiblrlrU9sVlkqnSKZ6Wt9HCZFAWANdfWgavJOtxWMWa_CDswzzoENUIIkc3sm9bjVDUn0F6SnaJMMwby_8I2YnTy8nsDVw8=@protonmail.com
State Accepted
Headers show
Series [bug#53370] Add Blur My Shell | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Charles Jan. 19, 2022, 4:22 p.m. UTC
Empty Message

Comments

Mathieu Othacehe Jan. 20, 2022, 1:27 p.m. UTC | #1
Hello,

> +    (synopsis "Blurs different parts of the GNOME Shell.")

I removed the dot here, as suggested by guix lint.

> +    (description "Blur My Shell adds a blur look to different parts of the GNOME
> +Shell, including the top panel, dash and overview.")

I wrapped this line to stay above the 78 columns limit.

Pushed as 30ae72b7986dbb0180ab48877cf8cd7cceb17c17.

Thanks,

Mathieu
diff mbox series

Patch

From 35f586d4f85d04ddc58433c6460706a479fd3200 Mon Sep 17 00:00:00 2001
From: Charles <charles.b.jackson@protonmail.com>
Date: Wed, 19 Jan 2022 10:19:24 -0600
Subject: [PATCH] gnu: gnome-xyz: Add gnome-shell-extension-blur-my-shell.

* gnu/packages/gnome-xyz.scm (gnome-shell-extension-blur-my-shell): New Variable.
---
 gnu/packages/gnome-xyz.scm | 40 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 17c6bd78e8..d6c4128f72 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -861,6 +861,46 @@  (define-public gnome-shell-extension-burn-my-windows
 animation of closing windowed applications.")
     (license license:gpl3)))
 
+(define-public gnome-shell-extension-blur-my-shell
+  (package
+    (name "gnome-shell-extension-blur-my-shell")
+    (version "27")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/aunetx/blur-my-shell")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0l318lgc2zrp8fskabiv28knwp3b5i2y8bd3164da4pkf1jsl468"))
+       (snippet
+        '(begin (delete-file "src/schemas/gschemas.compiled")))))
+    (build-system copy-build-system)
+    (arguments
+     `(#:install-plan
+       '(("." ,(string-append
+                "share/gnome-shell/extensions/"
+                "blur-my-shell@aunetx")
+          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+                            "\\.xml$" "\\.compiled$")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'cd-src
+           (lambda _ (chdir "src")))
+         (add-before 'install 'compile-schemas
+           (lambda _
+             (with-directory-excursion "schemas"
+               (invoke "glib-compile-schemas" ".")))))))
+    (native-inputs
+     (list (list glib "bin"))) ; for glib-compile-schemas
+    (home-page "https://github.com/aunetx/blur-my-shell")
+    (synopsis "Blurs different parts of the GNOME Shell.")
+    (description "Blur My Shell adds a blur look to different parts of the GNOME
+Shell, including the top panel, dash and overview.")
+    (license license:gpl3)))
+
 (define-public arc-theme
   (package
     (name "arc-theme")
-- 
2.34.0