diff mbox series

[bug#68133] gnu: glew: Fix cross-compiling.

Message ID 59dfe1d44bc0ea2cc713da3273c2e49b47e470cf.1703912009.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#68133] gnu: glew: Fix cross-compiling. | expand

Commit Message

Zheng Junjie Dec. 30, 2023, 4:53 a.m. UTC
gnu/packages/gl.scm(glew):
[arguments]<#:make-flags>: when cross-compiling, use {cc,strip}-for-target.

Change-Id: I365f6635120a85359083beb88cb138f09a99fe33
---
 gnu/packages/gl.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)


base-commit: f76ca2b0e894c244d5011a32b30dee8fd874e322

Comments

Mathieu Othacehe Jan. 3, 2024, 2:25 p.m. UTC | #1
Hello,

> gnu/packages/gl.scm(glew):
> [arguments]<#:make-flags>: when cross-compiling, use {cc,strip}-for-target.

When running:

./pre-inst-env guix build --target=aarch64-linux-gnu glew

I have the following error message:

--8<---------------cut here---------------start------------->8---
Run-time dependency libudev found: NO (tried pkgconfig and cmake)

../mesa-23.2.1/meson.build:1682:13: ERROR: Failed running '/gnu/store/fzmc9w4i1lyqi0v62w5jpdxi6h9cbnyh-llvm-for-mesa-15.0.7/bin/llvm-config', binary or interpreter not executable.
Possibly wrong architecture or the executable bit is not set.

A full log can be found at /tmp/guix-build-mesa-23.2.1.drv-0/build/meson-logs/meson-log.txt
error: in phase 'configure': uncaught exception:
--8<---------------cut here---------------end--------------->8---

Did I miss something?

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 192b5e84e0..56a1def37a 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -690,7 +690,12 @@  (define-public glew
                   #t))))
     (build-system gnu-build-system)
     (arguments
-     (list #:make-flags #~(list (string-append "GLEW_PREFIX=" #$output)
+     (list #:make-flags #~(list #$@(if (%current-target-system)
+                                       #~((string-append "CC=" #$(cc-for-target))
+                                          (string-append "LD=" #$(cc-for-target))
+                                          (string-append "STRIP=" #$(strip-for-target)))
+                                       #~())
+                                (string-append "GLEW_PREFIX=" #$output)
                                 (string-append "GLEW_DEST=" #$output))
            #:phases
            #~(modify-phases %standard-phases