diff mbox series

[bug#66823,gnome-team,v3,4/6] gnu: Add libcallaudio.

Message ID 59c821818e2cb3c70bb8e84b8c847cdfc010f8ed.1698780970.git.vivien@planete-kraus.eu
State New
Headers show
Series Add Calls, and inform upstreams | expand

Commit Message

Vivien Kraus Oct. 31, 2023, 7:34 p.m. UTC
* gnu/packages/telephony.scm (libcallaudio): New variable.

Change-Id: I41cfe14136858fe0b2a302a9ed8d624d44ad2a95
---
 gnu/packages/telephony.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index ff99b79ae4..0297391946 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -95,6 +95,7 @@  (define-module (gnu packages telephony)
   #:use-module (guix git-download)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system meson)
   #:use-module (guix build-system qt))
 
 (define-public phonesim
@@ -1169,3 +1170,27 @@  (define-public sofia-sip
 Protocol}}, @acronym{IM, Instant Messaging}, and many other real-time and
 person-to-person communication services.")
     (license license:lgpl2.1)))
+
+(define-public libcallaudio
+  (package
+    (name "libcallaudio")
+    (version "0.1.9")
+    (source (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/mobian1/callaudiod/")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0qnllb28101c2ss1k3iwr04gljfyjqmbla5csj6vkq1y63aagr9s"))))
+    (build-system meson-build-system)
+    (inputs (list alsa-lib glib pulseaudio))
+    (native-inputs
+     (list `(,glib "bin")          ;for gdbus-codegen
+           pkg-config))
+    (home-page "https://gitlab.com/mobian1/callaudiod")
+    (synopsis "Library for audio routing during voice calls")
+    (description "This package provides @command{callaudiod}, a daemon to
+route audio during phone calls, and a library.")
+    (license license:gpl3+)))