diff mbox series

[bug#64183] gnu: nomad-optimizer: Fix build.

Message ID 59b510efd866ee637409cae3d4be20af308c4824.1687227004.git.paul@apatience.com
State New
Headers show
Series [bug#64183] gnu: nomad-optimizer: Fix build. | expand

Commit Message

Paul A. Patience June 20, 2023, 2:10 a.m. UTC
* gnu/packages/maths.scm (nomad-optimizer)
[arguments]<#:phases>: Remove 'delete-superfluous-egg-info' phase.
---
 gnu/packages/maths.scm | 11 +----------
 1 file changed, 1 insertion(+), 10 deletions(-)


base-commit: d884fc9e2efecfba09af4694f5a13ad7fc6f704f
prerequisite-patch-id: 52027b181c066ac91bc56fc0af511a34f3516651
prerequisite-patch-id: 7ddddfb1646020c15a91ff8f00dd2bacc54162c9
prerequisite-patch-id: 7b8261c3b3ee237bfe47e1f478e72e7fd29fd683

Comments

Paul A. Patience June 20, 2023, 2:21 p.m. UTC | #1
Sorry, I didn't realize the prerequisite-patch-id fields were being added to the patch.
Please disregard them, they are unnecessary.

On Monday, June 19th, 2023 at 10:10 PM, Paul A. Patience <paul@apatience.com> wrote:
> base-commit: d884fc9e2efecfba09af4694f5a13ad7fc6f704f
> prerequisite-patch-id: 52027b181c066ac91bc56fc0af511a34f3516651
> prerequisite-patch-id: 7ddddfb1646020c15a91ff8f00dd2bacc54162c9
> prerequisite-patch-id: 7b8261c3b3ee237bfe47e1f478e72e7fd29fd683

Best regards,
Paul
Ludovic Courtès June 25, 2023, 8:59 p.m. UTC | #2
"Paul A. Patience" <paul@apatience.com> skribis:

> * gnu/packages/maths.scm (nomad-optimizer)
> [arguments]<#:phases>: Remove 'delete-superfluous-egg-info' phase.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 087cd9c71d..23cc5158e2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2388,16 +2388,7 @@  (define-public nomad-optimizer
                       (string-append builddir "/src/nomad ")))
                    (for-each
                     (lambda (f) (fix-exe-path dir f))
-                    '("param1.txt" "param2.txt" "param3.txt" "param10.txt")))))))
-
-         ;; The information in the .egg-info file is not kept up to date.
-         (add-after 'install 'delete-superfluous-egg-info
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (delete-file (string-append
-                           (site-packages inputs outputs)
-                           "/PyNomad-0.0.0-py"
-                           (python-version (assoc-ref inputs "python"))
-                           ".egg-info")))))))
+                    '("param1.txt" "param2.txt" "param3.txt" "param10.txt"))))))))))
     (home-page "https://www.gerad.ca/nomad/")
     (synopsis "Nonlinear optimization by mesh-adaptive direct search")
     (description