diff mbox series

[bug#66475,v2,4/4] gnu: orcus: Update to 0.19.0.

Message ID 59a3d5e428c780a7d863cd5e53b64addc5122169.1698783917.git.maxim.cournoyer@gmail.com
State New
Headers show
Series [bug#66475,v2,1/4] git-download: Add support for Git Large File Storage (LFS). | expand

Commit Message

Maxim Cournoyer Oct. 31, 2023, 8:25 p.m. UTC
* gnu/packages/libreoffice.scm (orcus): Update to 0.19.0.
[source]: Use git-fetch/lfs.
[arguments]: Use gexps.
[native-inputs]: Add autoconf, automake and libtool.

Change-Id: I76efbc57ca4acf8ffd5154a72e49b4aedd071a76
---

(no changes since v1)

 gnu/packages/libreoffice.scm | 30 +++++++++++++++---------------
 1 file changed, 15 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index e38095fb1e..572077a0ee 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -117,22 +117,22 @@  (define-public ixion
 (define-public orcus
   (package
     (name "orcus")
-    (version "0.17.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "http://kohei.us/files/orcus/src/lib"
-                           "orcus-" version ".tar.xz"))
-       (sha256
-        (base32
-         "1as04qb74jnlnwy4wh5jwaw2nnzgn2s3230ymvh3kx1w9r0rsl1h"))))
+    (version "0.19.0")
+    (source (origin
+              ;; The test suite requires data files store with Git Large
+              ;; File Storage.
+              (method git-fetch/lfs)
+              (uri (git-reference
+                    (url "https://gitlab.com/orcus/orcus")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "02prj6kgph56fkr89k8wlqarrmx65cq92863i4rrny5sqr8c2llr"))))
     (build-system gnu-build-system)
-    (arguments
-     `(#:configure-flags '("--disable-static")))
-    (native-inputs
-     (list pkg-config))
-    (inputs
-     (list ixion mdds python zlib))
+    (arguments (list #:configure-flags #~(list "--disable-static")))
+    (native-inputs (list autoconf automake libtool pkg-config))
+    (inputs (list ixion mdds python zlib))
     (home-page "https://gitlab.com/orcus/orcus")
     (synopsis "File import filter library for spreadsheet documents")
     (description "Orcus is a library that provides a collection of standalone