[bug#77579] gnu: efivar: Update to 39.

Message ID 593f7479c435b30f9c3c17f58924fba035e3ed51.1743952194.git.z572@z572.online
State New
Headers
Series [bug#77579] gnu: efivar: Update to 39. |

Commit Message

Zheng Junjie April 6, 2025, 3:09 p.m. UTC
  * gnu/packages/linux.scm (efivar): Update to 39.

Change-Id: Iaf9a94cd3f851d442b70b30b85d8e8e90ba4460c
---
 gnu/packages/linux.scm | 82 ++++++++++++++++++++----------------------
 1 file changed, 39 insertions(+), 43 deletions(-)


base-commit: 90279af10615cd74e4c52851f7fec797d4d0f682
prerequisite-patch-id: f6807c214a9924fb57a2a054dceba1802ba4536c
prerequisite-patch-id: b60437563c004733af4ad531ed0ca89b049e748f
prerequisite-patch-id: f923e612422f9021d997ea3824d4b97b1f022c65
  

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a6bffa2bb9d..4b1c7b398d2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8197,50 +8197,46 @@  (define-public radeontop
     (license license:gpl3)))
 
 (define-public efivar
-  ;; XXX: 15622b7e5761f3dde3f0e42081380b2b41639a48 fixes compilation on i686.
-  ;; ca48d3964d26f5e3b38d73655f19b1836b16bd2d fixes cross-compilation.
-  (let ((commit "ca48d3964d26f5e3b38d73655f19b1836b16bd2d")
-        (revision "0"))
-    (package
-      (name "efivar")
-      (version (git-version "38" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/rhboot/efivar")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0zsab3hcv1v53cxwkvsk09ifnwhs48a6xa3kxlwvs87yxswspvi8"))))
-      (build-system gnu-build-system)
-      (arguments
-       (list
-        ;; Tests require a UEFI system and is not detected in the chroot.
-        #:tests? #f
-        #:make-flags #~(list (string-append "prefix="
-                                            #$output)
-                             (string-append "libdir="
-                                            #$output "/lib")
-                             (string-append "CC="
-                                            #$(cc-for-target)) "HOSTCC=gcc"
-                             (string-append "LDFLAGS=-Wl,-rpath="
-                                            #$output "/lib"))
-        #:phases #~(modify-phases %standard-phases
-                     (add-after 'unpack 'build-deterministically
-                       (lambda _
-                         (substitute* "src/include/defaults.mk"
-                           ;; Don't use -march=native.
-                           (("-march=native")
-                            ""))))
-                     (delete 'configure))))
-      (native-inputs (list mandoc pkg-config))
-      (inputs (list popt))
-      (home-page "https://github.com/rhboot/efivar")
-      (synopsis "Tool and library to manipulate EFI variables")
-      (description "This package provides a library and a command line
+  (package
+    (name "efivar")
+    (version "39")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/rhboot/efivar")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1zd9dghg1z2rrsazv3d9rj7nik6kdqz42jiak65pipz7mpjn9zdk"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      ;; Tests require a UEFI system and is not detected in the chroot.
+      #:tests? #f
+      #:make-flags #~(list (string-append "prefix="
+                                          #$output)
+                           (string-append "libdir="
+                                          #$output "/lib")
+                           (string-append "CC="
+                                          #$(cc-for-target)) "HOSTCC=gcc"
+                                          (string-append "LDFLAGS=-Wl,-rpath="
+                                                         #$output "/lib"))
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'build-deterministically
+                     (lambda _
+                       (substitute* "src/include/defaults.mk"
+                         ;; Don't use -march=native.
+                         (("-march=native")
+                          ""))))
+                   (delete 'configure))))
+    (native-inputs (list mandoc pkg-config))
+    (inputs (list popt))
+    (home-page "https://github.com/rhboot/efivar")
+    (synopsis "Tool and library to manipulate EFI variables")
+    (description "This package provides a library and a command line
 interface to the variable facility of UEFI boot firmware.")
-      (license license:lgpl2.1+))))
+    (license license:lgpl2.1+)))
 
 (define-public efibootmgr
   (package