diff mbox series

[bug#69756,gnome-team,1/1] gnu: libgda: Disable failing tests.

Message ID 5932f75d4ad0e186371f49ecb0fe4606e9d441fe.1710263604.git.vivien@planete-kraus.eu
State New
Headers show
Series Fix libgda for gnome-team | expand

Commit Message

Vivien Kraus March 12, 2024, 5:12 p.m. UTC
* gnu/packages/patches/libgda-disable-data-proxy-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it here.
* gnu/packages/gnome.scm (libgda): Use it here.

Change-Id: I0a86fb75b1ad048eca99408750b26f4b8ff448c1
---
 gnu/local.mk                                  |  1 +
 gnu/packages/gnome.scm                        |  1 +
 .../libgda-disable-data-proxy-test.patch      | 59 +++++++++++++++++++
 3 files changed, 61 insertions(+)
 create mode 100644 gnu/packages/patches/libgda-disable-data-proxy-test.patch

Comments

Liliana Marie Prikler March 12, 2024, 5:59 p.m. UTC | #1
Am Dienstag, dem 12.03.2024 um 18:12 +0100 schrieb Vivien Kraus:
> * gnu/packages/patches/libgda-disable-data-proxy-test.patch: New
> file.
> * gnu/local.mk (dist_patch_DATA): Register it here.
> * gnu/packages/gnome.scm (libgda): Use it here.
> 
> Change-Id: I0a86fb75b1ad048eca99408750b26f4b8ff448c1
> ---
>  gnu/local.mk                                  |  1 +
>  gnu/packages/gnome.scm                        |  1 +
>  .../libgda-disable-data-proxy-test.patch      | 59
> +++++++++++++++++++
>  3 files changed, 61 insertions(+)
>  create mode 100644 gnu/packages/patches/libgda-disable-data-proxy-
> test.patch
> 
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 5546e33465..d85c11cba7 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -1578,6 +1578,7 @@ dist_patch_DATA
> =                                         \
>    %D%/packages/patches/libcyaml-libyaml-compat.patch           \
>    %D%/packages/patches/libexpected-use-provided-catch2.patch   \
>    %D%/packages/patches/libgda-cve-2021-39359.patch             \
> +  %D%/packages/patches/libgda-disable-data-proxy-test.patch     \
>    %D%/packages/patches/libgda-fix-build.patch                  \
>    %D%/packages/patches/libgda-fix-missing-initialization.patch \
>    %D%/packages/patches/libgda-skip-postgresql-tests.patch      \
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 97e7f25532..7e7d77a3a2 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -13505,6 +13505,7 @@ (define-public libgda
>         (sha256
>          (base32
> "0w564z7krgjk19r39mi5qn4kggpdg9ggbyn9pb4aavb61r14npwr"))
>         (patches (search-patches "libgda-cve-2021-39359.patch"
> +                                "libgda-disable-data-proxy-
> test.patch"
>                                  "libgda-fix-build.patch"
>                                  "libgda-fix-missing-
> initialization.patch"
>                                  "libgda-skip-postgresql-
> tests.patch"))))
> diff --git a/gnu/packages/patches/libgda-disable-data-proxy-
> test.patch b/gnu/packages/patches/libgda-disable-data-proxy-
> test.patch
> new file mode 100644
> index 0000000000..b93f9d3f9b
> --- /dev/null
> +++ b/gnu/packages/patches/libgda-disable-data-proxy-test.patch
> @@ -0,0 +1,59 @@
> +From c0bb1ed662011207ee13d5a20a70f9b55166aa13 Mon Sep 17 00:00:00
> 2001
> +From: Daniel Espinosa <esodan@gmail.com>
> +Date: Wed, 1 Nov 2023 15:00:40 -0500
> +Subject: [PATCH] GdaDataProxy: is no thread save so disabling its
> test
> +
> +Has been difficutl to reproduce the problem when this test
> +is running in Ci, so disabling until we can re-implement it
> +is the better choice
I assume the spelling is [sic]?

> +---
> + libgda/gda-data-proxy.h       |  4 +++-
> + tests/data-models/meson.build | 17 +++++++++--------
> + 2 files changed, 12 insertions(+), 9 deletions(-)
> +
> +diff --git a/libgda/gda-data-proxy.h b/libgda/gda-data-proxy.h
> +index 4c31ab69b..ba0fa72b3 100644
> +--- a/libgda/gda-data-proxy.h
> ++++ b/libgda/gda-data-proxy.h
> +@@ -77,7 +77,9 @@ struct _GdaDataProxyClass
> +  * @stability: Stable
> +  * @see_also: #GdaDataModel
> +  *
> +- * This object stores modifications to be made to a #GdaDataModel
> object which is proxied until the modifications are actually
> ++ *  This object, is no thread save, so use with care.
> ++ *
> ++ *  This object stores modifications to be made to a #GdaDataModel
> object which is proxied until the modifications are actually
> +  *  written to the #GdaDataModel, it can also filter the proxied
> data model to show only a subset (a defined number of continuous
> +  *  rows or by a filter to apply).
> +  *
> +diff --git a/tests/data-models/meson.build b/tests/data-
> models/meson.build
> +index a8c6a29d8..e0ec8692a 100644
> +--- a/tests/data-models/meson.build
> ++++ b/tests/data-models/meson.build
> +@@ -61,14 +61,15 @@ tchkdp = executable('check_data_proxy',
> +               ],
> +       install: false
> +       )
> +-test('DataProxy', tchkdp,
> +-      timeout: 100,
> +-      workdir: meson.current_build_dir(),
> +-      env: [
> +-              'GDA_TOP_SRC_DIR='+gda_top_src,
> +-              'GDA_TOP_BUILD_DIR='+gda_top_build
> +-              ]
> +-      )
> ++# This test is no thread save so disabling
> ++#test('DataProxy', tchkdp,
> ++#     timeout: 100,
> ++#     workdir: meson.current_build_dir(),
> ++#     env: [
> ++#             'GDA_TOP_SRC_DIR='+gda_top_src,
> ++#             'GDA_TOP_BUILD_DIR='+gda_top_build
> ++#             ]
> ++#     )
> + 
> + tchkmc = executable('check_model_copy',
> +       ['check_model_copy.c'] + common_sources,
> +-- 
> +GitLab
Otherwise LGTM
Vivien Kraus March 12, 2024, 6:03 p.m. UTC | #2
Le mardi 12 mars 2024 à 18:59 +0100, Liliana Marie Prikler a écrit :
> > +Has been difficutl to reproduce the problem when this test
> > +is running in Ci, so disabling until we can re-implement it
> > +is the better choice
> I assume the spelling is [sic]?
Correct, I would consider it rude to reword a commit that was accepted
by another project. Although it’s the first time I’m facing this
situation, so maybe the etiquette says something different.
Liliana Marie Prikler March 12, 2024, 9:12 p.m. UTC | #3
Am Dienstag, dem 12.03.2024 um 19:03 +0100 schrieb Vivien Kraus:
> Le mardi 12 mars 2024 à 18:59 +0100, Liliana Marie Prikler a écrit :
> > > +Has been difficutl to reproduce the problem when this test
> > > +is running in Ci, so disabling until we can re-implement it
> > > +is the better choice
> > I assume the spelling is [sic]?
> Correct, I would consider it rude to reword a commit that was
> accepted by another project. Although it’s the first time I’m facing
> this situation, so maybe the etiquette says something different.
Well, we indeed prefer upstreamed patches, but some upstreams also add
their fixes on top of such patches, which we'd have to incorporate as
well in this case.  In the case of libgda, it does however seem that
this is the newest modification to those files, so my worries were
somewhat unfounded.

Cheers
Christopher Baines March 16, 2024, 11 a.m. UTC | #4
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Dienstag, dem 12.03.2024 um 19:03 +0100 schrieb Vivien Kraus:
>> Le mardi 12 mars 2024 à 18:59 +0100, Liliana Marie Prikler a écrit :
>> > > +Has been difficutl to reproduce the problem when this test
>> > > +is running in Ci, so disabling until we can re-implement it
>> > > +is the better choice
>> > I assume the spelling is [sic]?
>>
>> Correct, I would consider it rude to reword a commit that was
>> accepted by another project. Although it’s the first time I’m facing
>> this situation, so maybe the etiquette says something different.
>
> Well, we indeed prefer upstreamed patches, but some upstreams also add
> their fixes on top of such patches, which we'd have to incorporate as
> well in this case.  In the case of libgda, it does however seem that
> this is the newest modification to those files, so my worries were
> somewhat unfounded.

Thanks both, I've pushed this to gnome-team as
64785a7941b5544f80c7f9cd286452fba296596a.

Chris
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 5546e33465..d85c11cba7 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1578,6 +1578,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/libcyaml-libyaml-compat.patch		\
   %D%/packages/patches/libexpected-use-provided-catch2.patch	\
   %D%/packages/patches/libgda-cve-2021-39359.patch		\
+  %D%/packages/patches/libgda-disable-data-proxy-test.patch     \
   %D%/packages/patches/libgda-fix-build.patch			\
   %D%/packages/patches/libgda-fix-missing-initialization.patch	\
   %D%/packages/patches/libgda-skip-postgresql-tests.patch	\
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 97e7f25532..7e7d77a3a2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13505,6 +13505,7 @@  (define-public libgda
        (sha256
         (base32 "0w564z7krgjk19r39mi5qn4kggpdg9ggbyn9pb4aavb61r14npwr"))
        (patches (search-patches "libgda-cve-2021-39359.patch"
+                                "libgda-disable-data-proxy-test.patch"
                                 "libgda-fix-build.patch"
                                 "libgda-fix-missing-initialization.patch"
                                 "libgda-skip-postgresql-tests.patch"))))
diff --git a/gnu/packages/patches/libgda-disable-data-proxy-test.patch b/gnu/packages/patches/libgda-disable-data-proxy-test.patch
new file mode 100644
index 0000000000..b93f9d3f9b
--- /dev/null
+++ b/gnu/packages/patches/libgda-disable-data-proxy-test.patch
@@ -0,0 +1,59 @@ 
+From c0bb1ed662011207ee13d5a20a70f9b55166aa13 Mon Sep 17 00:00:00 2001
+From: Daniel Espinosa <esodan@gmail.com>
+Date: Wed, 1 Nov 2023 15:00:40 -0500
+Subject: [PATCH] GdaDataProxy: is no thread save so disabling its test
+
+Has been difficutl to reproduce the problem when this test
+is running in Ci, so disabling until we can re-implement it
+is the better choice
+---
+ libgda/gda-data-proxy.h       |  4 +++-
+ tests/data-models/meson.build | 17 +++++++++--------
+ 2 files changed, 12 insertions(+), 9 deletions(-)
+
+diff --git a/libgda/gda-data-proxy.h b/libgda/gda-data-proxy.h
+index 4c31ab69b..ba0fa72b3 100644
+--- a/libgda/gda-data-proxy.h
++++ b/libgda/gda-data-proxy.h
+@@ -77,7 +77,9 @@ struct _GdaDataProxyClass
+  * @stability: Stable
+  * @see_also: #GdaDataModel
+  *
+- * This object stores modifications to be made to a #GdaDataModel object which is proxied until the modifications are actually
++ *  This object, is no thread save, so use with care.
++ *
++ *  This object stores modifications to be made to a #GdaDataModel object which is proxied until the modifications are actually
+  *  written to the #GdaDataModel, it can also filter the proxied data model to show only a subset (a defined number of continuous
+  *  rows or by a filter to apply).
+  *
+diff --git a/tests/data-models/meson.build b/tests/data-models/meson.build
+index a8c6a29d8..e0ec8692a 100644
+--- a/tests/data-models/meson.build
++++ b/tests/data-models/meson.build
+@@ -61,14 +61,15 @@ tchkdp = executable('check_data_proxy',
+ 		],
+ 	install: false
+ 	)
+-test('DataProxy', tchkdp,
+-	timeout: 100,
+-	workdir: meson.current_build_dir(),
+-	env: [
+-		'GDA_TOP_SRC_DIR='+gda_top_src,
+-		'GDA_TOP_BUILD_DIR='+gda_top_build
+-		]
+-	)
++# This test is no thread save so disabling
++#test('DataProxy', tchkdp,
++#	timeout: 100,
++#	workdir: meson.current_build_dir(),
++#	env: [
++#		'GDA_TOP_SRC_DIR='+gda_top_src,
++#		'GDA_TOP_BUILD_DIR='+gda_top_build
++#		]
++#	)
+ 
+ tchkmc = executable('check_model_copy',
+ 	['check_model_copy.c'] + common_sources,
+-- 
+GitLab
+