diff mbox series

[bug#65484] gnu: Add font-junicode.

Message ID 5925990d0d10d11c11a9e85de54147750fff36a3.1692852531.git.philip@philipmcgrath.com
State New
Headers show
Series [bug#65484] gnu: Add font-junicode. | expand

Commit Message

Philip McGrath Aug. 24, 2023, 4:50 a.m. UTC
* gnu/packages/fonts.scm (font-junicode): New variable.
---
 gnu/packages/fonts.scm | 32 +++++++++++++++++++++++++++++++-
 1 file changed, 31 insertions(+), 1 deletion(-)


base-commit: 3ce3466311953cc5f00a4fb34ff094a9a3501399
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index e881ab11cd..ee911559af 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -43,7 +43,7 @@ 
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2021-2023 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
-;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2022-2023 Philip McGrath <philip@philipmcgrath.com>
 ;;; Copyright © 2022 Kitzman <kitzman@disroot.org>
 ;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
@@ -1855,6 +1855,36 @@  (define-public font-iosevka-comfy
      version of the original, designed for enhanced readability.")
     (license license:silofl1.1)))
 
+(define-public font-junicode
+  (package
+    (name "font-junicode")
+    (version "2.001")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/psb1558/Junicode-font")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "13sm9sqb56i81zmgd0n14xzksy1ww88fz1wfgm5q2wrq6wgv0wmr"))))
+    (build-system font-build-system)
+    (home-page "https://github.com/psb1558/Junicode-font")
+    (synopsis "Unicode font for medievalists, linguists, and others")
+    (description "The Junicode font was developed for students and scholars of
+medieval Europe, but its large glyph repertoire also makes it useful as a
+general-purpose font.  Its visual design is based on the typography used by
+Oxford University Press in the late 17th and early 18th centuries.  The font
+implements the @acronym{MUFI, Medieval Unicode Font Initiative} recommendation
+for encoding ligatures, alternative letter forms, and other features of
+interest to medievalists using Unicode's Private Use Area.
+
+Junicode 2 is a major reworking of the font family.  Its OpenType programming
+has been rebuilt to support the creation of searchable, accessible electronic
+documents using the @acronym{MUFI} characters.  The family includes five
+weights and five widths in both Roman and Italic, plus variable fonts.")
+    (license license:silofl1.1)))
+
 (define-public font-sarasa-gothic
   (package
     (name "font-sarasa-gothic")