diff mbox series

[bug#69600,v2] gnu: mc: Update to 4.8.31

Message ID 59017f7b636416aef75f8a15e5402278b90d39df.1709857008.git.juli@incana.org
State New
Headers show
Series [bug#69600,v2] gnu: mc: Update to 4.8.31 | expand

Commit Message

Juliana Sims March 8, 2024, 12:16 a.m. UTC
From: Andy Tai <atai@atai.org>

Hello,

This patch failed to build because `mkstemp` could not find
"src/vfs/fish/fish.c.XXXXXX". Removing the reference to "src/vfs/fish/fish.c" in
the first `substitute*` form of the `patch-file-names` phase results in a
successful build. Attached is a patch making that very minor correction.

With that change made, this builds fine on x86 and aarch64, so I'm comfortable
saying it's good to go :)

Thanks,
Juli

* gnu/packages/mc.scm (mc): Update to 4.8.31

Change-Id: Ib610e76b2ef5e6c1a1f49f34073015c0b260ea77
---
 gnu/packages/mc.scm | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)


base-commit: 06e61f9cd2f4c317e19bf4eca817737af6544c42

Comments

Andy Tai March 8, 2024, 12:37 a.m. UTC | #1
the modified patch looks good to me.  Hope a commiter picks it up and commit

On Thu, Mar 7, 2024 at 4:31 PM Juliana Sims <juli@incana.org> wrote:
>
> From: Andy Tai <atai@atai.org>
>
> Hello,
>
> This patch failed to build because `mkstemp` could not find
> "src/vfs/fish/fish.c.XXXXXX". Removing the reference to "src/vfs/fish/fish.c" in
> the first `substitute*` form of the `patch-file-names` phase results in a
> successful build. Attached is a patch making that very minor correction.
>
> With that change made, this builds fine on x86 and aarch64, so I'm comfortable
> saying it's good to go :)
>
> Thanks,
> Juli
>
> * gnu/packages/mc.scm (mc): Update to 4.8.31
>
> Change-Id: Ib610e76b2ef5e6c1a1f49f34073015c0b260ea77
> ---
>  gnu/packages/mc.scm | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
> index 994f89f5248..8cf760ac53c 100644
> --- a/gnu/packages/mc.scm
> +++ b/gnu/packages/mc.scm
> @@ -40,14 +40,14 @@ (define-module (gnu packages mc)
>  (define-public mc
>    (package
>      (name "mc")
> -    (version "4.8.30")
> +    (version "4.8.31")
>      (source
>       (origin
>        (method url-fetch)
>        (uri (string-append "https://ftp.osuosl.org/pub/midnightcommander/mc-"
>                            version ".tar.xz"))
>        (sha256
> -       (base32 "1py7jm620lsas7rcv5j69608gdshmp25d9gx958hr5sb2jr3rg2y"))))
> +       (base32 "06mbnhxd2k29jah4wp1ciicw1gb51a5d3af43zivhxbncvw1q694"))))
>      (build-system gnu-build-system)
>      (arguments
>       (list
> @@ -68,7 +68,6 @@ (define-public mc
>                    (list "lib/utilunix.c"
>                          "src/filemanager/ext.c"
>                          "src/usermenu.c"
> -                        "src/vfs/fish/fish.c"
>                          ;; This file hard-codes other shells, but they're never
>                          ;; tried after mc's first choice (bash) is found.
>                          "lib/shell.c")
>
> base-commit: 06e61f9cd2f4c317e19bf4eca817737af6544c42
> --
> 2.41.0
>
diff mbox series

Patch

diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
index 994f89f5248..8cf760ac53c 100644
--- a/gnu/packages/mc.scm
+++ b/gnu/packages/mc.scm
@@ -40,14 +40,14 @@  (define-module (gnu packages mc)
 (define-public mc
   (package
     (name "mc")
-    (version "4.8.30")
+    (version "4.8.31")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "https://ftp.osuosl.org/pub/midnightcommander/mc-"
                           version ".tar.xz"))
       (sha256
-       (base32 "1py7jm620lsas7rcv5j69608gdshmp25d9gx958hr5sb2jr3rg2y"))))
+       (base32 "06mbnhxd2k29jah4wp1ciicw1gb51a5d3af43zivhxbncvw1q694"))))
     (build-system gnu-build-system)
     (arguments
      (list
@@ -68,7 +68,6 @@  (define-public mc
                   (list "lib/utilunix.c"
                         "src/filemanager/ext.c"
                         "src/usermenu.c"
-                        "src/vfs/fish/fish.c"
                         ;; This file hard-codes other shells, but they're never
                         ;; tried after mc's first choice (bash) is found.
                         "lib/shell.c")