diff mbox series

[bug#36920,42/43] gnu: Add rust-winapi-x86-64-pc-windows-gnu.

Message ID 58ba88e73c841fb9a91f40ce246673594c78d3cd.1564918220.git.efraim@flashner.co.il
State Accepted
Headers show
Series [bug#36920,01/43] gnu: crates-io.scm: Sort packages alphabetically. | expand

Commit Message

Efraim Flashner Aug. 4, 2019, 11:34 a.m. UTC
* gnu/packages/crates-io.scm (rust-winapi-x86-64-pc-windows-gnu): New
variable.
---
 gnu/packages/crates-io.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Ivan Petkov Aug. 11, 2019, 2:08 a.m. UTC | #1
Hi Efraim,

I skimmed through the package definitions, all look sensible to me.
I was even able to successfully build each of the packages with —rounds=2!

However, I wasn’t able to run guix lint on them since an exception was raised.
I’m not sure if that is pointing to anything missing in the definitions themselves,
or if there is something wrong with one of the lint implementations…

—Ivan
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 36632653d4..23592f839b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -903,3 +903,24 @@  i686-pc-windows-gnu target.  Please don't use this crate directly, depend on
 @code{winapi} instead.")
     (license (list license:asl2.0
                    license:expat))))
+
+(define-public rust-winapi-x86-64-pc-windows-gnu
+  (package
+    (name "rust-winapi-x86-64-pc-windows-gnu")
+    (version "0.4.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "winapi-x86_64-pc-windows-gnu" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "0gqq64czqb64kskjryj8isp62m2sgvx25yyj3kpc2myh85w24bki"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/retep998/winapi-rs")
+    (synopsis "Import libraries for the x86_64-pc-windows-gnu target")
+    (description "This package provides import libraries for the
+x86_64-pc-windows-gnu target.  Please don't use this crate directly, depend on
+@code{winapi} instead.")
+    (license (list license:asl2.0
+                   license:expat))))