diff mbox series

[bug#71842] gnu: Add emacs-meyvn

Message ID 58b425680d500254f3e6a6f5bec664b7c651ec44.1719692584.git.daniel.szmulewicz@gmail.com
State New
Headers show
Series [bug#71842] gnu: Add emacs-meyvn | expand

Commit Message

Daniel Szmulewicz June 29, 2024, 8:23 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-meyvn): New variable.

Change-Id: I4e97ce9745ad999b0db74644a82828e450135725
---
 gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: 385fb14f6482a955fbef4d4b21fccb3473beddd8

Comments

Nicolas Goaziou June 30, 2024, 5:46 p.m. UTC | #1
Hello,

Daniel Szmulewicz <daniel.szmulewicz@gmail.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-meyvn): New variable.

I let-bound the commit and fixed the hash, and applied your patch. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 903c22bbcb..2fa6d198f1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -142,6 +142,8 @@ 
 ;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
 ;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
 ;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2024 Daniel Szmulewicz <daniel.szmulewicz@gmail.com>
+
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1860,6 +1862,33 @@  (define-public emacs-mct
     (license (list license:gpl3+
                    license:fdl1.3+)))) ; GFDLv1.3+ for the manual
 
+(define-public emacs-meyvn
+  (package
+    (name "emacs-meyvn")
+    (version "1.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/danielsz/meyvn-el")
+             (commit "f2b809da1d1bf66f1a215a0e5c64f95d10118b76")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1flxvaj8j5kg4r0cvns8z1xixgvsavq1i27z28j97m8dmndihihf"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-cider
+                             emacs-dash
+                             emacs-geiser
+                             emacs-parseclj
+                             emacs-parseedn
+                             emacs-projectile
+                             emacs-s))
+    (home-page "https://github.com/danielsz/meyvn-el")
+    (synopsis "Emacs client for the Meyvn build tool")
+    (description
+     "This package provides an Emacs client for the @url{https://meyvn.org, Meyvn} build tool.")
+    (license license:gpl3+)))
+
 (define-public emacs-fzf
   (let ((commit "21912ebc7e1084aa88c9d8b7715e782a3978ed23")
         (revision "0"))