[bug#76746,04/13] gnu: Add python-websockets-14.
Commit Message
* gnu/packages/python-web.scm (python-websockets-14): New variable.
[source]{uri}: Use new GitHub repository.
[home-page]: Likewise.
(python-websockets): Inherit from python-websockets-14.
Change-Id: I91b90bf4e407f6726b0ea1b95b7a69f1bd9471ec
---
gnu/packages/python-web.scm | 26 +++++++++++++++++++++-----
1 file changed, 21 insertions(+), 5 deletions(-)
@@ -7957,20 +7957,20 @@ (define-public python-warcio
files.")
(license license:asl2.0)))
-(define-public python-websockets
+(define-public python-websockets-14
(package
(name "python-websockets")
- (version "13.1")
+ (version "14.2")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/aaugustin/websockets")
+ (url "https://github.com/python-websockets/websockets")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "1dx3rf6fmg4ir9cfcn1fil446qz879cwrjq2rcz5zvl71xkw6hb3"))))
+ "0j8x1xn3m1jcghwy42y6ibspr9kwazcgdz1c90i0jxdgj50xxbiz"))))
(build-system pyproject-build-system)
(arguments
(list #:phases
@@ -7985,7 +7985,7 @@ (define-public python-websockets
(native-inputs
(list python-setuptools
python-wheel))
- (home-page "https://github.com/aaugustin/websockets")
+ (home-page "https://github.com/python-websockets/websockets")
(synopsis
"Python implementation of the WebSocket Protocol (RFC 6455 & 7692)")
(description
@@ -7996,6 +7996,22 @@ (define-public python-websockets
it provides an elegant coroutine-based API.")
(license license:bsd-3)))
+(define-public python-websockets
+ (package
+ (inherit python-websockets-14)
+ (name "python-websockets")
+ (version "13.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/python-websockets/websockets")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dx3rf6fmg4ir9cfcn1fil446qz879cwrjq2rcz5zvl71xkw6hb3"))))))
+
(define-public python-selenium
(package
(name "python-selenium")