diff mbox series

[bug#70393] gnu: python-pydevd: Use gdb/pinned.

Message ID 58a0c85ad35db14c9fed7d5791b43d30882e13bf.1713169547.git.mail@cbaines.net
State New
Headers show
Series [bug#70393] gnu: python-pydevd: Use gdb/pinned. | expand

Commit Message

Christopher Baines April 15, 2024, 8:25 a.m. UTC
To allow gdb to be updated more easily.

* gnu/packages/python-xyz.scm (python-pydevd)[inputs]: Use gdb/pinned.

Change-Id: Icf417f89933bc190bf4c0d869c199cfe50d463ef
---
 gnu/packages/python-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: 4e7337536ba41e888a601c92fada8a4adca9d2c6

Comments

Ludovic Courtès April 15, 2024, 4:27 p.m. UTC | #1
Hi!

Christopher Baines <mail@cbaines.net> skribis:

> To allow gdb to be updated more easily.
>
> * gnu/packages/python-xyz.scm (python-pydevd)[inputs]: Use gdb/pinned.
>
> Change-Id: Icf417f89933bc190bf4c0d869c199cfe50d463ef

[...]

> -      (inputs (list coreutils gdb procps))
> +      (inputs (list coreutils gdb/pinned procps))
>        (home-page "https://github.com/fabioz/PyDev.Debugger/")
>        (synopsis "Python debugger")

If PyDev uses GDB, then it’ll be stuck with an older version of GDB?
Maybe that’s OK?  (I know nothing about PyDev and how it uses GDB so I
can’t really judge whether it’s OK.)

Ludo’.
Christopher Baines April 17, 2024, 1:43 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hi!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> To allow gdb to be updated more easily.
>>
>> * gnu/packages/python-xyz.scm (python-pydevd)[inputs]: Use gdb/pinned.
>>
>> Change-Id: Icf417f89933bc190bf4c0d869c199cfe50d463ef
>
> [...]
>
>> -      (inputs (list coreutils gdb procps))
>> +      (inputs (list coreutils gdb/pinned procps))
>>        (home-page "https://github.com/fabioz/PyDev.Debugger/")
>>        (synopsis "Python debugger")
>
> If PyDev uses GDB, then it’ll be stuck with an older version of GDB?
> Maybe that’s OK?  (I know nothing about PyDev and how it uses GDB so I
> can’t really judge whether it’s OK.)

I don't really know either, but at least this will allow updating gdb
without rebuilding a bunch of Python things.
Lars-Dominik Braun April 25, 2024, 3:09 p.m. UTC | #3
Hi Chris,

> > If PyDev uses GDB, then it’ll be stuck with an older version of GDB?
> > Maybe that’s OK?  (I know nothing about PyDev and how it uses GDB so I
> > can’t really judge whether it’s OK.)
> 
> I don't really know either, but at least this will allow updating gdb
> without rebuilding a bunch of Python things.

I don’t see anything that would prevent pydevd running on a pinned/older
GDB version. We might want to verify when we update python-pydevd, but
right now it just attaches to the process and injects a shared object
– that’s all. So, LGTM.

Lars
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 92566abfed..a19422aa4a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16471,7 +16471,7 @@  (define-public python-pydevd
              python-pytest-xdist
              python-trio
              python-untangle))
-      (inputs (list coreutils gdb procps))
+      (inputs (list coreutils gdb/pinned procps))
       (home-page "https://github.com/fabioz/PyDev.Debugger/")
       (synopsis "Python debugger")
       (description "PyDev.Debugger is a capable Python debugger used in PyDev