diff mbox series

[bug#66008,gnome-team,3/4] gnu: editorconfig-core-c: Update to 0.12.6.

Message ID 589183fbafa856ba8505d287bf6effcdf0e37694.1694801847.git.vivien@planete-kraus.eu
State New
Headers show
Series Fix and update gnome-text-editor | expand

Commit Message

Vivien Kraus Sept. 15, 2023, 5:50 p.m. UTC
* gnu/packages/gnome.scm (editorconfig-core-c): Update to 0.12.6.
[#:phase 'disable-failing-tests]: Disable a couple of failing tests.
---
 gnu/packages/gnome.scm | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)

Comments

Liliana Marie Prikler Sept. 15, 2023, 8:20 p.m. UTC | #1
Am Freitag, dem 15.09.2023 um 19:50 +0200 schrieb Vivien Kraus:
> * gnu/packages/gnome.scm (editorconfig-core-c): Update to 0.12.6.
> [#:phase 'disable-failing-tests]: Disable a couple of failing tests.
Should be "[#:phases]: Add ‘disable-failing-tests’." since you're
freshly adding it.  Otherwise, it'd make more sense to mention what
tests you're disabling.


Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8535ad784e..77c0c14344 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5471,7 +5471,7 @@  (define-public gnome-terminal
 (define-public editorconfig-core-c
   (package
     (name "editorconfig-core-c")
-    (version "0.12.5")
+    (version "0.12.6")
     (source
       (origin
         (method git-fetch)
@@ -5480,7 +5480,7 @@  (define-public editorconfig-core-c
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "073sh18y0v8wm10iphaia54pkdmwylalccpn1k5i9dwyfjzgj7yg"))))
+         (base32 "05qllpls3r95nfl14gqq3cv4lisf07fgn85n52w8blc5pfl1h93g"))))
     (build-system cmake-build-system)
     (arguments
      '(#:phases
@@ -5490,6 +5490,13 @@  (define-public editorconfig-core-c
              (let ((tests (assoc-ref inputs "tests")))
                (copy-recursively tests "tests"))
              #t))
+         (add-after 'insert-tests 'disable-failing-tests
+           (lambda _
+             (substitute* "tests/parser/CMakeLists.txt"
+               (("# Test max property name and values")
+                "# Disabled: test max property name and values\nif(FALSE)\n")
+               (("# Test max section names")
+                "endif()\n\n# Test max section names"))))
          (add-after 'install 'delete-static-library
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))