diff mbox series

[bug#71581,05/10] gnu: Remove node-llparse-frontend-bootstrap.

Message ID 57d153fd217dc3cce4aff2d4a75ba12c4d2f7b7a.1718714173.git.ashvithshetty10@gmail.com
State New
Headers show
Series [bug#71581,01/10] gnu: llhttp-bootstrap: Update to 6.1.0. | expand

Commit Message

Ashvith Shetty June 18, 2024, 12:38 p.m. UTC
* gnu/packages/node.scm (node-llparse-frontend-bootstrap): Delete variable.

Change-Id: I8ac4906741fcb49a1a794c37db75735098369729
---
 gnu/packages/node.scm | 62 -------------------------------------------
 1 file changed, 62 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 3474f2eabb..923332d518 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -509,68 +509,6 @@  (define-public node-llparse-builder-bootstrap
     (description "This package builds graphs for consumption by llparse.")
     (license license:expat)))
 
-(define-public node-llparse-frontend-bootstrap
-  (package
-    (name "node-llparse-frontend")
-    (version "3.0.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/indutny/llparse-frontend.git")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1rm9g4ifyip30svm5cgnf0gx7d45jgh4mpf2hkd092xhngmfvicc"))
-       (modules '((guix build utils)))
-       (snippet
-        '(begin
-           ;; Fix imports for esbuild.
-           ;; https://github.com/evanw/esbuild/issues/477
-           (substitute* '("src/frontend.ts"
-                          "src/code/field-value.ts"
-                          "src/container/index.ts"
-                          "src/container/wrap.ts"
-                          "src/node/sequence.ts"
-                          "src/node/single.ts"
-                          "src/node/table-lookup.ts"
-                          "src/trie/index.ts")
-             (("\\* as assert") "assert")
-             (("\\* as debugAPI") "debugAPI"))
-           #t))))
-    (build-system node-build-system)
-    (arguments
-     `(#:node ,node-bootstrap
-       #:tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'patch-dependencies 'delete-dependencies
-           (lambda args
-             (delete-dependencies `("@types/debug"
-                                    "@types/mocha"
-                                    "@types/node"
-                                    "mocha"
-                                    "ts-node"
-                                    "tslint"
-                                    "typescript"))))
-         (replace 'build
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((esbuild (search-input-file inputs "/bin/esbuild")))
-               (invoke esbuild
-                       "--platform=node"
-                       "--outfile=lib/frontend.js"
-                       "--bundle"
-                       "src/frontend.ts")))))))
-    (inputs
-     (list node-debug-bootstrap node-llparse-builder-bootstrap))
-    (native-inputs
-     (list esbuild))
-    (home-page "https://github.com/indutny/llparse-frontend#readme")
-    (properties '((hidden? . #t)))
-    (synopsis "Frontend for the llparse compiler")
-    (description "This package is a frontend for the llparse compiler.")
-    (license license:expat)))
-
 (define-public llhttp-bootstrap
   (package
     (inherit llhttp)