diff mbox series

[bug#38129] gnu: Add sherlock-lv2.

Message ID 57b24a50e1feeed51edf264b6bb97480@posteo.net
State Accepted
Headers show
Series [bug#38129] gnu: Add sherlock-lv2. | expand

Commit Message

Alexandros Theodotou Nov. 8, 2019, 11:05 a.m. UTC
From 5207795bcce201e019c33bb0274e06a460cf6c3f Mon Sep 17 00:00:00 2001
 From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:59:52 +0000
Subject: [PATCH] gnu: Add sherlock-lv2.

* gnu/packages/music.scm: (sherlock-lv2): New variable.
---
  gnu/packages/music.scm | 34 ++++++++++++++++++++++++++++++++++
  1 file changed, 34 insertions(+)

+debugging of event signal flows inside plugin graphs.")
+    (home-page "https://open-music-kontrollers.ch/lv2/sherlock/")
+    (license license:artistic2.0)))

Comments

Marius Bakke Nov. 10, 2019, 9:31 p.m. UTC | #1
Alexandros,

Thanks for these patches.  I think your MUA might have mangled these
patches somehow, as many of them are "corrupt" according to git.  Can
you try to resend these?  I'll comment on the patches individually
meanwhile.

Alexandros Theodotou <alex@zrythm.org> writes:

>  From 5207795bcce201e019c33bb0274e06a460cf6c3f Mon Sep 17 00:00:00 2001
>  From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:59:52 +0000
> Subject: [PATCH] gnu: Add sherlock-lv2.
>
> * gnu/packages/music.scm: (sherlock-lv2): New variable.

[...]

> +(define-public sherlock-lv2
> +  (package
> +    (name "sherlock-lv2")
> +    (version "0.20.0")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (string-append
> +               "https://git.open-music-kontrollers.ch/lv2/"
> +               "sherlock.lv2/snapshot/sherlock.lv2-"
> +               version ".tar.xz"))
> +        (sha256
> +          (base32
> +            "1c5xajpss9h8lbyx160bbzg8va50n2d74qwnxig9sf468rzmha1y"))))
> +    (build-system meson-build-system)
> +    (inputs
> +     `(("glibc" ,glibc)

I don't think this is needed?

> +       ("libx11" ,libx11)
> +       ("mesa" ,mesa)
> +       ("serd" ,serd)
> +       ("sratom" ,sratom)))
> +    (native-inputs
> +     `(("flex" ,flex)
> +       ("lv2" ,lv2)
> +       ("sord" ,sord)

I don't know anything about LV2 and sord, are these inputs really only
used for the build process itself?  :-)

> +       ("pkg-config" ,pkg-config)))
> +    (synopsis "Investigative LV2 plugin bundle")
> +    (description "The Sherlock plugin bundle contains LV2 plugins for
> +visualizing LV2 atom, MIDI and OSC events. They can be used for 
> monitoring and
> +debugging of event signal flows inside plugin graphs.")

Two spaces after periods, as per 'guix lint'.
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..95cc0ff93c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@ 
  ;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
  ;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
  ;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -4699,3 +4700,36 @@  You can also get metadata about the playing track 
such as the artist and title
  for integration into status line generators or other command-line 
tools.")
      (home-page "https://github.com/altdesktop/playerctl")
      (license license:lgpl3+)))
+
+(define-public sherlock-lv2
+  (package
+    (name "sherlock-lv2")
+    (version "0.20.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://git.open-music-kontrollers.ch/lv2/"
+               "sherlock.lv2/snapshot/sherlock.lv2-"
+               version ".tar.xz"))
+        (sha256
+          (base32
+            "1c5xajpss9h8lbyx160bbzg8va50n2d74qwnxig9sf468rzmha1y"))))
+    (build-system meson-build-system)
+    (inputs
+     `(("glibc" ,glibc)
+       ("libx11" ,libx11)
+       ("mesa" ,mesa)
+       ("serd" ,serd)
+       ("sratom" ,sratom)))
+    (native-inputs
+     `(("flex" ,flex)
+       ("lv2" ,lv2)
+       ("sord" ,sord)
+       ("pkg-config" ,pkg-config)))
+    (synopsis "Investigative LV2 plugin bundle")
+    (description "The Sherlock plugin bundle contains LV2 plugins for
+visualizing LV2 atom, MIDI and OSC events. They can be used for 
monitoring and