diff mbox series

[bug#39574] gnu: Add libcyaml.

Message ID 5794eac4fb9ef5e9215527c24cecfb7fc362d6a7.camel@zrythm.org
State Accepted
Headers show
Series [bug#39574] gnu: Add libcyaml. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou Feb. 12, 2020, 12:55 p.m. UTC
Hi,

This patch adds libcyaml, a C library for parsing YAML into/from C
structs. It will be required as a dependency to the zrythm package in
its next release.

Thanks,
Alex

Comments

vasilii.smirnov--- via Guix-patches" via Feb. 12, 2020, 11:56 p.m. UTC | #1
Alexandros,

Pushed as eb642f3d247ee0c74122017354c57bdce028eb57, with the 
indentation tweaks below (C-M-q in emacs, and moving the comment 
in-line).

Thanks!

T G-R
diff mbox series

Patch

From 968b188c9de49a6ad4cbcecfc4a6cde1e37f3411 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 12 Feb 2020 12:51:37 +0000
Subject: [PATCH] gnu: Add libcyaml.

* gnu/packages/web.scm (libcyaml): New variable.
---
 gnu/packages/web.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0f20cf205c..19051b5f85 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -37,6 +37,7 @@ 
 ;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.org>
 ;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1435,6 +1436,48 @@  hash/signatures.")
         (base32
          "1karpcfgacgppa82wm2drcfn2kb6q2wqfykf5nrhy20sci2i2a3q"))))))
 
+(define-public libcyaml
+  (package
+    (name "libcyaml")
+    (version "1.0.1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/tlsa/libcyaml.git")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "0h5ydyqdl8kzh526np3jsi0pm7ks16nh1hjkdsjcd6pacw7y6i6z"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+             (string-append "CC=gcc"))
+       #:phases
+       (modify-phases %standard-phases
+         ;; no configure script
+         (delete 'configure)
+         (replace 'check
+           (lambda _
+             (setenv "CC" "gcc")
+             (invoke "make" "test"))))))
+    (inputs
+      `(("libyaml" ,libyaml)))
+    (native-inputs
+      `(("pkg-config", pkg-config)
+        ("git", git)))
+    (synopsis "C library for reading and writing YAML")
+    (description
+      "LibCYAML is a C library written in ISO C11 for reading and writing
+structured YAML documents.  The fundamental idea behind CYAML is to allow
+applications to construct schemas which describe both the permissible
+structure of the YAML documents to read/write, and the C data structure(s)
+in which the loaded data is arranged in memory.")
+    (home-page "https://github.com/tlsa/libcyaml")
+    (license license:isc)))
+
 (define-public libquvi-scripts
   (package
     (name "libquvi-scripts")
-- 
2.25.0