[bug#75384,4/4] gnu: node-lts: Update to 22.12.0.
Commit Message
From: Jelle Licht <jlicht@fsfe.org>
* gnu/packages/node.scm (node-lts): Update to 22.12.0.
[#:phases]<delete-problematic-tests>: Delete tests that fail due to the build
container. Delete tests that require a DNS resolver.
[inputs]: Replace c-ares by c-ares-for-node-lts.
Replace icu4c by icu4c-73.
[native-inputs]: Replace c-ares by c-ares-for-node-lts.
Replace icu4c by icu4c-73.
Change-Id: I8cbc790bd82c55b48f8917e6405b37569b29dc1c
---
gnu/packages/node.scm | 18 ++++++++++--------
1 file changed, 10 insertions(+), 8 deletions(-)
@@ -750,14 +750,14 @@ (define-public llhttp-bootstrap
(define-public node-lts
(package
(inherit node-bootstrap)
- (version "20.18.1")
+ (version "22.12.0")
(source (origin
(method url-fetch)
(uri (string-append "https://nodejs.org/dist/v" version
"/node-v" version ".tar.gz"))
(sha256
(base32
- "1f180vgr6lrg4gs48q5c414j5sdwaqqp1vnswwr3pvryhznqrbav"))
+ "1qrcn9hm85bmh81ircaa0vmxrqmiip1iwczvpsyn9sdn0b0ffmri"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -838,14 +838,16 @@ (define-public node-lts
;; seem to be indicative of real problems in practice.
(for-each delete-file
'("test/parallel/test-cluster-primary-error.js"
- "test/parallel/test-cluster-primary-kill.js"))
+ "test/parallel/test-cluster-primary-kill.js"
+ "test/parallel/test-node-run.js"))
;; These require a DNS resolver.
(for-each delete-file
'("test/parallel/test-dns.js"
"test/parallel/test-dns-lookupService-promises.js"
"test/parallel/test-net-socket-connect-without-cb.js"
- "test/parallel/test-tcp-wrap-listen.js"))
+ "test/parallel/test-tcp-wrap-listen.js"
+ "test/report/test-report-exclude-network.js"))
;; These tests require networking.
(for-each delete-file
@@ -956,9 +958,9 @@ (define-public node-lts
(chmod file #o555))))))))
(native-inputs
(list ;; Runtime dependencies for binaries used as a bootstrap.
- c-ares
+ c-ares-for-node-lts
brotli
- icu4c
+ icu4c-73
libuv-for-node-lts
`(,nghttp2 "lib")
openssl
@@ -973,8 +975,8 @@ (define-public node-lts
(inputs
(list bash-minimal
coreutils
- c-ares
- icu4c
+ c-ares-for-node-lts
+ icu4c-73
libuv-for-node-lts
llhttp-bootstrap
brotli