diff mbox series

[bug#68556,gnome-team,v3,3/7] gnu: gnome-shell-extension-noannoyance: Switch to fork.

Message ID 577b4b7594e011fb93f1c8c030281759e3e7affa.1705709466.git.vivien@planete-kraus.eu
State New
Headers show
Series Update extensions (2/5 replaced, 2/5 no solution, 1/5 redundant) | expand

Commit Message

Vivien Kraus Jan. 17, 2024, 10:32 p.m. UTC
The NoAnnoyance “v2” project has not been ported to GNOME 44, so we switch to
a maintained fork.

* gnu/packages/gnome-xyz.scm (gnome-shell-extension-noannoyance): Switch to
the fork.
[arguments]: Convert to list of G-Expressions.

Change-Id: Ic74d832020dfe3857e1abf450f5d7876cc921a28
---
 gnu/packages/gnome-xyz.scm | 15 ++++++++-------
 1 file changed, 8 insertions(+), 7 deletions(-)

Comments

Liliana Marie Prikler Jan. 20, 2024, 12:40 a.m. UTC | #1
Am Mittwoch, dem 17.01.2024 um 23:32 +0100 schrieb Vivien Kraus:
> The NoAnnoyance “v2” project has not been ported to GNOME 44, so we
> switch to
> a maintained fork.
> 
> * gnu/packages/gnome-xyz.scm (gnome-shell-extension-noannoyance):
> Switch to
> the fork.
> [arguments]: Convert to list of G-Expressions.
> 
> Change-Id: Ic74d832020dfe3857e1abf450f5d7876cc921a28
> ---
>  gnu/packages/gnome-xyz.scm | 15 ++++++++-------
>  1 file changed, 8 insertions(+), 7 deletions(-)
> 
> diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> index b6c1f6d3cb..7ba5ed1af4 100644
> --- a/gnu/packages/gnome-xyz.scm
> +++ b/gnu/packages/gnome-xyz.scm
> @@ -953,25 +953,26 @@ (define-public gnome-shell-extension-dash-to-
> panel
>  
>  (define-public gnome-shell-extension-noannoyance
>    (let ((revision "1")
> -        (commit "b759d10fd2799bc084007fdd927b62637c3dbd2c"))
> +        (commit "5e9e6a1878d2a1d961f5d59505f15339c5b7e17e"))
Remember to bump the revision.
>      (package
> +      ;; This is the “fork” version:
> +      ;;
> https://extensions.gnome.org/extension/6109/noannoyance-fork/
The comment here is not great.  What does "This is the fork version"
mean when standing alone?  To me, it means absolutely nothing, despite
knowing the context behind.

Maybe explain "While the original version at <first link> is not
updated to current gnome, this fork <fork link> supports newer
versions." or something like that.
>        (name "gnome-shell-extension-noannoyance")
> -      ;; XXX: There is no version noted anywhere in the source. 
> Thus, infer it
> -      ;;      from
> <https://extensions.gnome.org/extension/2182/noannoyance/>.
>        (version (git-version "16" revision commit))
>        (source (origin
>                  (method git-fetch)
>                  (uri (git-reference
> -                      (url "https://github.com/bdaase/noannoyance")
> +                      (url
> "https://github.com/jirkavrba/noannoyance")
>                        (commit commit)))
>                  (sha256
>                   (base32
> -                 
> "0hh7fdqvx54h9j41ia2jl0nq1d5i66k7blw41ya6hkh7201r4anp"))
> +                 
> "0br9zrwvn499kh3db84hhw1kl02jpchwb5ldfp892p15vwih8yrf"))
>                  (file-name (git-file-name name version))))
>        (build-system copy-build-system)
>        (arguments
> -       '(#:install-plan
> -         '(("."
> "share/gnome-shell/extensions/noannoyance@daase.net"))))
> +       (list
> +        #:install-plan
> +        #~'(("."
> "share/gnome-shell/extensions/noannoyance@vrba.dev"))))
>        (synopsis "Remove 'Window is ready' annotation")
>        (description "One of the many extensions that remove this
> message.
>  It uses ES6 syntax and claims to be more actively maintained than
> others.")

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b6c1f6d3cb..7ba5ed1af4 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -953,25 +953,26 @@  (define-public gnome-shell-extension-dash-to-panel
 
 (define-public gnome-shell-extension-noannoyance
   (let ((revision "1")
-        (commit "b759d10fd2799bc084007fdd927b62637c3dbd2c"))
+        (commit "5e9e6a1878d2a1d961f5d59505f15339c5b7e17e"))
     (package
+      ;; This is the “fork” version:
+      ;; https://extensions.gnome.org/extension/6109/noannoyance-fork/
       (name "gnome-shell-extension-noannoyance")
-      ;; XXX: There is no version noted anywhere in the source.  Thus, infer it
-      ;;      from <https://extensions.gnome.org/extension/2182/noannoyance/>.
       (version (git-version "16" revision commit))
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
-                      (url "https://github.com/bdaase/noannoyance")
+                      (url "https://github.com/jirkavrba/noannoyance")
                       (commit commit)))
                 (sha256
                  (base32
-                  "0hh7fdqvx54h9j41ia2jl0nq1d5i66k7blw41ya6hkh7201r4anp"))
+                  "0br9zrwvn499kh3db84hhw1kl02jpchwb5ldfp892p15vwih8yrf"))
                 (file-name (git-file-name name version))))
       (build-system copy-build-system)
       (arguments
-       '(#:install-plan
-         '(("." "share/gnome-shell/extensions/noannoyance@daase.net"))))
+       (list
+        #:install-plan
+        #~'(("." "share/gnome-shell/extensions/noannoyance@vrba.dev"))))
       (synopsis "Remove 'Window is ready' annotation")
       (description "One of the many extensions that remove this message.
 It uses ES6 syntax and claims to be more actively maintained than others.")