diff mbox series

[bug#64408] gnu: Add privacybrowser.

Message ID 5746518.DvuYhMxLoT@soren-desktop
State New
Headers show
Series [bug#64408] gnu: Add privacybrowser. | expand

Commit Message

Soren Stoutner Jan. 23, 2024, 5:59 a.m. UTC
Attached is an updated patch.

On Sunday, January 14, 2024 2:17:00 AM MST Clément Lassieur wrote:
> On Sat, Jan 13 2024, Soren Stoutner via Guix-patches via wrote:
> > Clément
> > 
> > On Saturday, January 13, 2024 3:45:08 AM MST Clément Lassieur wrote:
> >> On Mon, Oct 16 2023, Soren Stoutner via Guix-patches via wrote:
> >> > Note that for KHelpCenter to function, it must be specified at runtime.
> > 
> > For
> > 
> >> > example:
> >> > 
> >> > guix shell privacybrowser khelpcenter -- privacybrowser
> >> 
> >> Maybe it should be a propagated input then?
> 
> You use the propagated-inputs field instead of the inputs field.  The
> consequence is that installing "PrivacyBrowser" will install the
> propagated inputs too.  Same with "guix shell".  So "guix shell
> privacybrowser -- privacybrowser" will work.
> 
> > How is that done?
> > 
> >> Also does it have to be in a specific file?  I imagine it could fit in
> >> qt.scm?
> > 
> > You can put it wherever it makes the most sense.  If you would like to 
place
> > it inside of another scm, I would imagine that web-browsers.scm is 
probably
> > the most logical location.
> 
> Indeed, sounds like the right place.
> 
> Can you send an updated patch?
diff mbox series

Patch

From e194cdf0955c66f2eb2d41cece5b8e4c0ed465b3 Mon Sep 17 00:00:00 2001
Message-Id: <e194cdf0955c66f2eb2d41cece5b8e4c0ed465b3.1705989200.git.soren@stoutner.com>
From: Soren Stoutner <soren@stoutner.com>
Date: Mon, 22 Jan 2024 22:48:55 -0700
Subject: [PATCH] gnu: privacybrowser: Add Privacy Browser 0.5.

* gnu/packages/web-browsers.scm: (privacybrowser): Add Privacy
Browser 0.5.

Change-Id: I4e8d624ef10acb15a6d699f4b9432e6bce4e1322
---
 gnu/packages/web-browsers.scm | 41 +++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 71289dbb2b..4d0f1c1ea5 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2021 Christopher Howard <christopher@librehacker.com>
 ;;; Copyright © 2023 Herman Rimm <herman@rimm.ee>
+;;; Copyright © 2023-2024 Soren Stoutner <soren@stoutner.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -44,6 +45,7 @@  (define-module (gnu packages web-browsers)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system qt)
   #:use-module (guix download)
   #:use-module (guix gexp)
   #:use-module (guix git-download)
@@ -73,6 +75,8 @@  (define-module (gnu packages web-browsers)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
   #:use-module (gnu packages imagemagick)
+  #:use-module (gnu packages kde-frameworks)
+  #:use-module (gnu packages kde-systemtools)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libidn)
   #:use-module (gnu packages libunistring)
@@ -458,6 +462,43 @@  (define-public kristall
                      ;; for breeze-stylesheet
                      license:expat)))))
 
+(define-public privacybrowser
+  (package
+    (name "privacybrowser")
+    (version "0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://download.stoutner.com/"
+                           "privacybrowser-pc/privacybrowser-" version
+                           ".tar.xz"))
+       (sha256
+        (base32 "1rywfmmw535bs0h3i4yrif3xmz2a4flp04bmhqdlbri4h1pk7x2y"))))
+    (build-system qt-build-system)
+    (native-inputs
+     (list extra-cmake-modules))
+    (inputs
+     (list breeze-icons
+           kcrash
+           kdbusaddons
+           khelpcenter
+           ki18n
+           kio
+           knotifications
+           qtsvg-5
+           qtwebengine-5))
+    (propagated-inputs
+     (list khelpcenter))
+     ; khelpcenter needs to be propagates so that F1 work inside
+     ; privacybrowser.
+    (home-page "https://www.stoutner.com/privacy-browser-pc/")
+    (synopsis "Web browser that respects your privacy")
+    (description "Privacy Browser is a web browser based on Qt WebEngine
+with a focus on privacy and security.  Features like JavaScript and
+cookies are disabled by default but are easy to automatically enable
+on-the-fly or by domain.")
+    (license license:gpl3+)))
+
 (define-public qutebrowser
   (package
     (name "qutebrowser")

base-commit: f7c0ccb1866b559dc2ce0c538d10a150822824c8
-- 
2.39.2