diff mbox series

[bug#69200] gnu: ngtcp2: Update to 1.3.0.

Message ID 5713fd0203f2b3db3b100d1f251f51664a5a81c3.1708176182.git.~@wolfsden.cz
State New
Headers show
Series [bug#69200] gnu: ngtcp2: Update to 1.3.0. | expand

Commit Message

Tomas Volf Feb. 17, 2024, 1:23 p.m. UTC
* gnu/packages/networking.scm (ngtcp2): Update to 1.3.0.

Change-Id: I5c1b411d4e7af0dc2bd33829b7c9ee1f2ac12a1e
---
 gnu/packages/networking.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)


base-commit: 7142f6df77bfac4fdc8da65a7caae915df945a8b

Comments

Jelle Licht Feb. 20, 2024, 7:58 p.m. UTC | #1
Tomas Volf <~@wolfsden.cz> writes:

> * gnu/packages/networking.scm (ngtcp2): Update to 1.3.0.
>
> Change-Id: I5c1b411d4e7af0dc2bd33829b7c9ee1f2ac12a1e

Pushed to master with some small adjustments to the commit message.  I
also changed the sources back to using a .tar.xz file, as those seemed to
be work fine too (and of course changed the hash accordingly).

- Jelle
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 9b472500bc..962db33981 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4557,22 +4557,22 @@  (define-public nbd
 (define-public ngtcp2
   (package
     (name "ngtcp2")
-    (version "1.2.0")
+    (version "1.3.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/ngtcp2/ngtcp2/"
                            "releases/download/v" version "/"
-                           "ngtcp2-" version ".tar.xz"))
+                           "ngtcp2-" version ".tar.gz"))
        (sha256
-        (base32 "158acn01df6sxqjqx4h948phpcgc2da88aiqn9p2jqgqph48brxh"))))
+        (base32 "1r63sg4hfrg2fs8ny2h2n0pkbn7wlf8bl47qiy80yfm82nn48hkx"))))
     (build-system gnu-build-system)
     (arguments
      (list
       #:configure-flags
       ;; openssl package does not support QUIC interface, so just gnutls
       #~(list "--with-gnutls")))
-    (native-inputs (list cunit pkg-config))
+    (native-inputs (list pkg-config))
     (inputs (list gnutls))
     (home-page "https://nghttp2.org/ngtcp2/")
     (synopsis "QUIC protocol implementation")