diff mbox series

[bug#71204,1/2] gnu: guix: Add imagemagick, perl and use full graphviz.

Message ID 570f7c8fffe33eb297ee1ff6f018aeb8e3264c54.1716697564.git.maxim.cournoyer@gmail.com
State New
Headers show
Series [bug#71204,1/2] gnu: guix: Add imagemagick, perl and use full graphviz. | expand

Commit Message

Maxim Cournoyer May 26, 2024, 4:26 a.m. UTC
This makes it possible to run 'make distcheck' in a 'guix shell -D guix'
environment.

* gnu/packages/package-management.scm (guix)
[native-inputs]: Replace graphviz-minimal with graphviz.  Add imagemagick and
perl.

Change-Id: Ie400c622d8fc77108df29c03e11f36159d6f6238
---
 gnu/packages/package-management.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)


base-commit: 77771036f0970083c146b709d792d128f4235125

Comments

Zheng Junjie May 26, 2024, 7:46 a.m. UTC | #1
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> This makes it possible to run 'make distcheck' in a 'guix shell -D guix'

I think maybe should add them to manifest.scm? And just 'guix shell' or
'guix shell -m manifest.scm'?


> environment.
>
> * gnu/packages/package-management.scm (guix)
> [native-inputs]: Replace graphviz-minimal with graphviz.  Add imagemagick and
> perl.
>
> Change-Id: Ie400c622d8fc77108df29c03e11f36159d6f6238
> ---
>  gnu/packages/package-management.scm | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
> index 862de9f942..2f1434d5be 100644
> --- a/gnu/packages/package-management.scm
> +++ b/gnu/packages/package-management.scm
> @@ -490,8 +490,10 @@ (define-public guix
>                         ("automake" ,automake)
>                         ("gettext" ,gettext-minimal)
>                         ("texinfo" ,texinfo)
> -                       ("graphviz" ,graphviz-minimal)
> +                       ("graphviz" ,graphviz) ;non-minimal for PDF support
>                         ("font-ghostscript" ,font-ghostscript) ;fonts for 'dot'
> +                       ("imagemagick" ,imagemagick) ;for 'make dist'
> +                       ("perl" ,perl)               ;for 'make dist'
>                         ("help2man" ,help2man)
>                         ("po4a" ,po4a-minimal)))
>        (inputs
>
> base-commit: 77771036f0970083c146b709d792d128f4235125
Maxim Cournoyer May 26, 2024, 12:09 p.m. UTC | #2
Hi Zheng,

Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> This makes it possible to run 'make distcheck' in a 'guix shell -D guix'

> I think maybe should add them to manifest.scm? And just 'guix shell' or
> 'guix shell -m manifest.scm'?

I think it's nice that 'make distcheck' works out of the box, even for
'guix shell -D guix ...'.  According to 'guix size' the
new $GUIX_ENVIRONMENT produced with the added inputs do not add any
weight, so were probably already transitively referenced.

Also see PATCH 2/2 where I augment the manifest.scm file with
git:send-email and friends.
Zheng Junjie May 27, 2024, 10:59 a.m. UTC | #3
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hi Zheng,
>
> Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:
>
>> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>>
>>> This makes it possible to run 'make distcheck' in a 'guix shell -D guix'
>
>> I think maybe should add them to manifest.scm? And just 'guix shell' or
>> 'guix shell -m manifest.scm'?
>
> I think it's nice that 'make distcheck' works out of the box, even for
> 'guix shell -D guix ...'.  According to 'guix size' the
> new $GUIX_ENVIRONMENT produced with the added inputs do not add any

ok, LGTM. 

> weight, so were probably already transitively referenced.
>
> Also see PATCH 2/2 where I augment the manifest.scm file with
> git:send-email and friends.
diff mbox series

Patch

diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 862de9f942..2f1434d5be 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -490,8 +490,10 @@  (define-public guix
                        ("automake" ,automake)
                        ("gettext" ,gettext-minimal)
                        ("texinfo" ,texinfo)
-                       ("graphviz" ,graphviz-minimal)
+                       ("graphviz" ,graphviz) ;non-minimal for PDF support
                        ("font-ghostscript" ,font-ghostscript) ;fonts for 'dot'
+                       ("imagemagick" ,imagemagick) ;for 'make dist'
+                       ("perl" ,perl)               ;for 'make dist'
                        ("help2man" ,help2man)
                        ("po4a" ,po4a-minimal)))
       (inputs