diff mbox series

[bug#71810,1/3] gnu: smplayer: Update to 22.2.0

Message ID 5708714cc9e486ffdadcb2408cf6479ecbecd220.1719525499.git.attila@lendvai.name
State New
Headers show
Series [bug#71810,1/3] gnu: smplayer: Update to 22.2.0 | expand

Commit Message

Attila Lendvai June 27, 2024, 9:58 p.m. UTC
From: Attila Lendvai <attila@lendvai.name>

* gnu/packages/video.scm (smplayer) [origin]: Build from the git repo.
[arguments]: Remove LRELEASE kludge.

Change-Id: Iff065784a2b2ef677807e4194ca04ce2ec501fef
---

the rationale for sending three patches is that if someone
wants to experiment with different versions, then they can
easily grab them from the git history.

and i had to go step-by-step anyway to find out what version
broke, and what was the difference, so i recorded the steps.

 gnu/packages/video.scm | 29 ++++++++---------------------
 1 file changed, 8 insertions(+), 21 deletions(-)


base-commit: 78d946b01162fbe986c6768800e8cfd6e70e67e5
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 77cdfe9078c..731403f5291 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2711,15 +2711,15 @@  (define-public mpv
 (define-public smplayer
   (package
     (name "smplayer")
-    (version "21.10.0")
+    (version "22.2.0")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "mirror://sourceforge/smplayer/SMPlayer/" version
-                    "/smplayer-" version ".tar.bz2"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/smplayer-dev/smplayer")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
-               (base32
-                "12nvcl0cfix1xay9hfi7856vg4lpv8y5b0a22212bsjbvl5g22rc"))))
+               (base32 "0mcvpm86n9l0nwavnaa1n2jfalgrzdfh92sdjnwx1iga89m4k55s"))))
     (build-system qt-build-system)
     (native-inputs
      (list qttools-5))
@@ -2728,23 +2728,10 @@  (define-public smplayer
     (arguments
      (list #:tests? #false              ; no tests
            #:make-flags #~(list (string-append "PREFIX=" #$output)
-                                (string-append "CC=" #+(cc-for-target))
-                                ;; A KLUDGE to turn off invoking lrelease on the
-                                ;; project for now, because it fails consistently
-                                ;; with "WARNING: Could not find qmake spec
-                                ;; 'default'". See below.
-                                "LRELEASE=true")
+                                (string-append "CC=" #+(cc-for-target)))
            #:phases
            #~(modify-phases %standard-phases
                (delete 'configure)
-               ;; Due to the above, we must run lrelease separately on each .ts file
-               ;; (as opposed to running `lrelease-pro smplayer.pro` for the entire
-               ;; project, as the Makefile does normally without the above kludge).
-               (add-after 'build 'compile-ts-files
-                 (lambda _
-                   (for-each (lambda (file)
-                               (invoke "lrelease" file))
-                             (find-files "./" "\\.ts$"))))
                (add-after 'install 'wrap-executable
                  (lambda* (#:key inputs outputs #:allow-other-keys)
                    (let* ((out (assoc-ref outputs "out"))