diff mbox series

[bug#55994,3/3] gnu: Add trytond-google-maps.

Message ID 56ea1fd3f0ddfe27f61b53512664a33fda7bec63.1655293324.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#55994,1/3] gnu: Add python-geomet. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel June 15, 2022, 11:44 a.m. UTC
* gnu/packages/tryton.scm (trytond-google-maps): New variable.
---
 gnu/packages/tryton.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index c105d4fe2d..32f38d0892 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1767,6 +1767,27 @@  from the UNECE.  Supported formats are:
 information system) support to Tryton.")
     (license license:gpl3+)))
 
+(define-public trytond-google-maps
+  (package
+    (name "trytond-google-maps")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_google_maps" version))
+       (sha256
+        (base32 "1wgcnl3r1017vicbf7rkcwv2ffrhaah90hcajn3i78bywjdag6nj"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "trytond_google_maps"))
+    (native-inputs (%standard-trytond-native-inputs))
+    (propagated-inputs (list trytond trytond-party))
+    (home-page "https://docs.tryton.org/projects/modules-google-maps")
+    (synopsis "Tryton module to link addresses to Google Maps")
+    (description "The @emph{Trytond Google Maps} Tryton module adds a new URL
+field on the party addresses.  This link open the Google Maps page on the
+default browser with the map centered on the selected address.")
+    (license license:gpl3+)))
+
 (define-public trytond-incoterm
   (package
     (name "trytond-incoterm")