diff mbox series

[bug#68859,v2] gnu: Add cl-modf.

Message ID 56e554151a26bd59da3fb75e94a6b9f84c1ed12a.1706747362.git.charles@charje.net
State New
Headers show
Series [bug#68859,v2] gnu: Add cl-modf. | expand

Commit Message

Charles Feb. 1, 2024, 12:29 a.m. UTC
* gnu/packages/lisp-xyz.scm (sbcl-modf, cl-modf, ecl-modf): New variables.

Change-Id: Ic7e8e4511ca537531a7d9aa134e671aca060aa09
---
I just saw that you change the git-file-name to use the package name, so I updated this patch to do the same.

 gnu/packages/lisp-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)


base-commit: bf7991a8c767abd32cfb2c92e3d57665a7cabf00
prerequisite-patch-id: bcaf8eb7f369a54bf47e9c7ef7b94fda2295de4a

Comments

Guillaume Le Vaillant Feb. 5, 2024, 1:37 p.m. UTC | #1
Charles <charles@charje.net> skribis:

> I just saw that you change the git-file-name to use the package name, so I updated this patch to do the same.

Usually when packaging the xyz Common Lisp package, we use "cl-xyz" as
name for the sources instead of "sbcl-xyz" to indicate that the sources
are not specific to sbcl (as they are also used for the cl-xyz and
ecl-xyz packages).

Patch applied as 87f5876e60922a032b253c43964d2e455d14955a.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b764d6b885..8c9ee783a4 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11552,6 +11552,42 @@  (define-public ecl-fset
      ;; Tests fails on ECL with "The function FSET::MAKE-CHAR is undefined".
      '(#:tests? #f))))
 
+(define-public sbcl-modf
+  (let ((commit "dea93fe62c6bf7f66f32f52ac0c555aedbf7abad")
+        (revision "0"))
+    (package
+      (name "sbcl-modf")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/smithzvk/modf")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1aap7ldy7lv942khp026pgndgdzfkkqa9xcq1ykinrmflrgdazay"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       (list sbcl-alexandria
+             sbcl-closer-mop
+             sbcl-iterate))
+      (native-inputs
+       (list sbcl-stefil))
+      (home-page "https://github.com/smithzvk/modf")
+      (synopsis "@code{setf} like macro for functional programming in Common Lisp")
+      (description "This library simplifies functional programming in Common
+Lisp by making it easier to make new data structures with specified changes in
+place.")
+      (license license:bsd-3))))
+
+(define-public cl-modf
+  (sbcl-package->cl-source-package sbcl-modf))
+
+(define-public ecl-modf
+  (sbcl-package->ecl-package sbcl-modf))
+
 (define-public sbcl-cl-cont
   (let ((commit "fc1fa7e6eb64894fdca13e688e6015fad5290d2a")
         (revision "1"))