diff mbox series

[bug#65654] gnu: dbus-cxx: Update to 2.4.0.

Message ID 5686dc3309451165e7875231057a98030399a085.1693479069.git.iyzsong@member.fsf.org
State New
Headers show
Series [bug#65654] gnu: dbus-cxx: Update to 2.4.0. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via Aug. 31, 2023, 10:51 a.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/glib.scm (dbus-cxx): Update to 2.4.0.
[source]: Switch to git-fetch.
[arguments]: Use g-exps.  Adjust configure-flags.
Skip 'test-machine-uuid-method' test.
[inputs]: Remove python and glibmm.  Move libsigc++ to...
[propagated-inputs]: ...here.  Add glib.
[native-inputs]: Remove m4.
[license]: Change to lgpl3+ and bsd-3.
---
 gnu/packages/glib.scm | 36 ++++++++++++++++++++----------------
 1 file changed, 20 insertions(+), 16 deletions(-)


base-commit: 299d0463d54c97b237deb2fe9e464108544344c0

Comments

Liliana Marie Prikler Aug. 31, 2023, 4:58 p.m. UTC | #1
Am Donnerstag, dem 31.08.2023 um 18:51 +0800 schrieb iyzsong@envs.net:
> From: 宋文武 <iyzsong@member.fsf.org>
> 
> * gnu/packages/glib.scm (dbus-cxx): Update to 2.4.0.
> [source]: Switch to git-fetch.
> [arguments]: Use g-exps.  Adjust configure-flags.
> Skip 'test-machine-uuid-method' test.
> [inputs]: Remove python and glibmm.  Move libsigc++ to...
> [propagated-inputs]: ...here.  Add glib.
> [native-inputs]: Remove m4.
> [license]: Change to lgpl3+ and bsd-3.
> ---
>  gnu/packages/glib.scm | 36 ++++++++++++++++++++----------------
>  1 file changed, 20 insertions(+), 16 deletions(-)
> 
> diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
> index f523706449..043d506a9e 100644
> --- a/gnu/packages/glib.scm
> +++ b/gnu/packages/glib.scm
> @@ -1255,26 +1255,30 @@ (define-public dbus-c++
>  (define-public dbus-cxx
>    (package
>      (name "dbus-cxx")
> -    (version "0.12.0")
> +    (version "2.4.0")
Version appears to be correct.  As for whether the package works or
not, I'll defer to CI.
>      (source (origin
> -              (method url-fetch)
> -              (uri (string-append "mirror://sourceforge/dbus-
> cxx/dbus-cxx/"
> -                                  version "/dbus-cxx-" version
> ".tar.gz"))
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/dbus-cxx/dbus-cxx")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
>                (sha256
>                 (base32
> -               
> "1acsgpkd9v7b9jdc79ijmh9dbdfrzgkwkaff518i3zpk7y6g5mzw"))))
> +               
> "0c9q2bjs4m66zq0qysyip8fnkvvjpj46rkjcvw15nhmfhzbq16ag"))))
>      (build-system cmake-build-system)
>      (arguments
> -     `(#:configure-flags '("-DENABLE_TESTS=ON"
> -                           "-DENABLE_TOOLS=ON"
> -                           "-DENABLE_GLIBMM=ON")))
> -    (inputs (list dbus
> -                  libsigc++
> -                  glibmm
> -                  python
> -                  popt
> -                  expat))
> -    (native-inputs (list pkg-config m4))
> +     (list #:configure-flags #~(list "-DBUILD_TESTING=ON"
> +                                     "-DENABLE_TOOLS=ON"
> +                                     "-DENABLE_GLIB_SUPPORT=ON")
> +           #:phases
> +           #~(modify-phases %standard-phases
> +               (replace 'check
> +                 (lambda _
> +                   ;; XXX: Missing /etc/machine-id in the build
> environment.
> +                   (invoke "ctest" "-E" "test-machine-uuid-
> method"))))))
> +    (propagated-inputs (list glib libsigc++))
> +    (inputs (list dbus expat popt))
> +    (native-inputs (list pkg-config))
>      (synopsis "C++ wrapper for dbus")
>      (description "Dbus-cxx is a C++ wrapper for dbus.\n
>  It exposes the C API to allow direct manipulation and
> @@ -1288,7 +1292,7 @@ (define-public dbus-cxx
>  Some codes examples can be find at:
>  @url{https://dbus-cxx.github.io/examples.html}")
>      (home-page "https://dbus-cxx.github.io/")
> -    (license license:gpl3)))
> +    (license (list license:lgpl3+ license:bsd-3))))
I think we should also mention tools/libcppgenerate or otherwise
unbundle it; judging by the name, it appears to be a native input, but
I might be wrong about that.

Cheers
Maxim Cournoyer Sept. 1, 2023, 3:48 a.m. UTC | #2
Hi 宋文武!

iyzsong@envs.net writes:

> From: 宋文武 <iyzsong@member.fsf.org>
>
> * gnu/packages/glib.scm (dbus-cxx): Update to 2.4.0.
> [source]: Switch to git-fetch.
> [arguments]: Use g-exps.  Adjust configure-flags.
> Skip 'test-machine-uuid-method' test.
> [inputs]: Remove python and glibmm.  Move libsigc++ to...
> [propagated-inputs]: ...here.  Add glib.
> [native-inputs]: Remove m4.
> [license]: Change to lgpl3+ and bsd-3.
> ---
>  gnu/packages/glib.scm | 36 ++++++++++++++++++++----------------
>  1 file changed, 20 insertions(+), 16 deletions(-)
>
> diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
> index f523706449..043d506a9e 100644
> --- a/gnu/packages/glib.scm
> +++ b/gnu/packages/glib.scm
> @@ -1255,26 +1255,30 @@ (define-public dbus-c++
>  (define-public dbus-cxx
>    (package
>      (name "dbus-cxx")
> -    (version "0.12.0")
> +    (version "2.4.0")

Wooh, big update!

>      (source (origin
> -              (method url-fetch)
> -              (uri (string-append "mirror://sourceforge/dbus-cxx/dbus-cxx/"
> -                                  version "/dbus-cxx-" version ".tar.gz"))
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/dbus-cxx/dbus-cxx")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
>                (sha256
>                 (base32
> -                "1acsgpkd9v7b9jdc79ijmh9dbdfrzgkwkaff518i3zpk7y6g5mzw"))))
> +                "0c9q2bjs4m66zq0qysyip8fnkvvjpj46rkjcvw15nhmfhzbq16ag"))))
>      (build-system cmake-build-system)
>      (arguments
> -     `(#:configure-flags '("-DENABLE_TESTS=ON"
> -                           "-DENABLE_TOOLS=ON"
> -                           "-DENABLE_GLIBMM=ON")))
> -    (inputs (list dbus
> -                  libsigc++
> -                  glibmm
> -                  python
> -                  popt
> -                  expat))
> -    (native-inputs (list pkg-config m4))
> +     (list #:configure-flags #~(list "-DBUILD_TESTING=ON"
> +                                     "-DENABLE_TOOLS=ON"
> +                                     "-DENABLE_GLIB_SUPPORT=ON")
> +           #:phases
> +           #~(modify-phases %standard-phases
> +               (replace 'check
> +                 (lambda _
> +                   ;; XXX: Missing /etc/machine-id in the build environment.
> +                   (invoke "ctest" "-E" "test-machine-uuid-method"))))))
> +    (propagated-inputs (list glib libsigc++))

Propagation being frowned upon, a comment should explain why it's needed
here (referenced in headers or Requires of .pc files is the classic
reason).

> +    (inputs (list dbus expat popt))
> +    (native-inputs (list pkg-config))
>      (synopsis "C++ wrapper for dbus")
>      (description "Dbus-cxx is a C++ wrapper for dbus.\n
>  It exposes the C API to allow direct manipulation and
> @@ -1288,7 +1292,7 @@ (define-public dbus-cxx
>  Some codes examples can be find at:
>  @url{https://dbus-cxx.github.io/examples.html}")
>      (home-page "https://dbus-cxx.github.io/")
> -    (license license:gpl3)))
> +    (license (list license:lgpl3+ license:bsd-3))))

Perhaps add an inline comment: ;dual licensed

Otherwise LGTM, assuming CI is happy.
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index f523706449..043d506a9e 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1255,26 +1255,30 @@  (define-public dbus-c++
 (define-public dbus-cxx
   (package
     (name "dbus-cxx")
-    (version "0.12.0")
+    (version "2.4.0")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://sourceforge/dbus-cxx/dbus-cxx/"
-                                  version "/dbus-cxx-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dbus-cxx/dbus-cxx")
+                    (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1acsgpkd9v7b9jdc79ijmh9dbdfrzgkwkaff518i3zpk7y6g5mzw"))))
+                "0c9q2bjs4m66zq0qysyip8fnkvvjpj46rkjcvw15nhmfhzbq16ag"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags '("-DENABLE_TESTS=ON"
-                           "-DENABLE_TOOLS=ON"
-                           "-DENABLE_GLIBMM=ON")))
-    (inputs (list dbus
-                  libsigc++
-                  glibmm
-                  python
-                  popt
-                  expat))
-    (native-inputs (list pkg-config m4))
+     (list #:configure-flags #~(list "-DBUILD_TESTING=ON"
+                                     "-DENABLE_TOOLS=ON"
+                                     "-DENABLE_GLIB_SUPPORT=ON")
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda _
+                   ;; XXX: Missing /etc/machine-id in the build environment.
+                   (invoke "ctest" "-E" "test-machine-uuid-method"))))))
+    (propagated-inputs (list glib libsigc++))
+    (inputs (list dbus expat popt))
+    (native-inputs (list pkg-config))
     (synopsis "C++ wrapper for dbus")
     (description "Dbus-cxx is a C++ wrapper for dbus.\n
 It exposes the C API to allow direct manipulation and
@@ -1288,7 +1292,7 @@  (define-public dbus-cxx
 Some codes examples can be find at:
 @url{https://dbus-cxx.github.io/examples.html}")
     (home-page "https://dbus-cxx.github.io/")
-    (license license:gpl3)))
+    (license (list license:lgpl3+ license:bsd-3))))
 
 (define-public sdbus-c++
   ;; Use the latest commit, which includes unreleased fixes to the pkg-config