diff mbox series

[bug#35619] WIP version of postfix.scm

Message ID 567ff351-d0f4-4143-af85-4a0e5c83c012@www.fastmail.com
State Accepted
Headers show
Series [bug#35619] WIP version of postfix.scm | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Brant Gardner May 7, 2019, 3:15 p.m. UTC
I've gotten it to the point where it builds but does not install - Postfix seems to have a non-standard install procedure and I'm not sure how to proceed.

'guix lint' is mostly happy with it and I tried to follow standards but I'm still new at this so any comments are appreciated.

Thank you!

--
Brant Gardner

Comments

Ricardo Wurmus June 12, 2022, 10:29 a.m. UTC | #1
I just rebased all of this, changed the input style to plain lists,
removed trailing #t from build phases, and upgraded postfix to 3.7.

What is missing to get this merged?
Ricardo Wurmus Sept. 7, 2023, 4:13 p.m. UTC | #2
I rebased again and upgraded to 3.7.7.

What remains to be done?  People above mentioned something about setuid,
but I don’t know if that’s something that needs to change in the service
definition or the example configuration, or both.
Ricardo Wurmus Sept. 7, 2023, 7:32 p.m. UTC | #3
Okay, I made a few more changes:

- fixed typos

- fixed installation locations so the executables aren’t dumped into
  the prefix directory
  
- let the postfix-service-type conditionally extend
  setuid-program-service-type to setgid on the executables

What’s missing:

- rough tests to see if this works at all
- documentation of the service

Any takers?
diff mbox series

Patch

From 212731a40d9ad0f41c757d42aacc98efbf3f9ddf Mon Sep 17 00:00:00 2001
From: Brant Gardner <brantcgardner@brantware.com>
Date: Tue, 7 May 2019 10:09:08 -0500
Subject: [PATCH] gnu: Add postfix WIP.

* gnu/packages/postfix.scm (postfix): New public variable.
---
 gnu/packages/postfix.scm | 85 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 85 insertions(+)
 create mode 100644 gnu/packages/postfix.scm

diff --git a/gnu/packages/postfix.scm b/gnu/packages/postfix.scm
new file mode 100644
index 0000000000..6585c108e4
--- /dev/null
+++ b/gnu/packages/postfix.scm
@@ -0,0 +1,85 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Brant Gardner <bcg@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages postfix)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages base)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages dbm)
+  #:use-module (gnu packages onc-rpc)
+  #:use-module (gnu packages perl))
+
+(define-public postfix
+  (package
+    (name "postfix")
+    (version "3.4.5")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append
+                "ftp://ftp.porcupine.org/mirrors/project-history/postfix/official/postfix-"
+                version ".tar.gz"))
+              (sha256
+               (base32
+                "17riwr21i9p1h17wpagfiwkpx9bbx7dy4gpdl219a11akm7saawb"))))
+    (build-system gnu-build-system)
+    (arguments '(#:phases
+                 (modify-phases %standard-phases
+                   (add-before 'build 'patch-/bin/sh
+                     (lambda _
+                       (substitute* (find-files "." "^Makefile.in")
+                         (("/bin/sh") (which "sh")))
+                       #t))
+                   (add-before 'build 'auxlibs
+                     (lambda _
+                       (setenv "AUXLIBS"
+                               "-lnsl -lresolv") ; Required, but postfix OS
+                                                 ; detection in leaves these
+                                                 ; unset for Guix
+                       #t))
+                   (add-before 'build 'patch-/usr/include
+                     (lambda* (#:key inputs #:allow-other-keys)
+                       (substitute* '("makedefs")
+                         (("/usr/include") (string-append (assoc-ref
+                                                           inputs "bdb")
+                                                          "/include"))) #t))
+                   (add-before 'build 'configure-postfix ; Move configuration folder
+                     (lambda* (#:key outputs #:allow-other-keys)
+                       (invoke "make" "makefiles"
+                               (string-append "CCARGS=-DDEF_CONFIG_DIR=\\\""
+                                (assoc-ref outputs "out") "/etc\\\"")) #t))
+                   (delete 'configure) ; no configure script
+                   (delete 'check)))) ; no check
+    (inputs `(("bdb" ,bdb)
+              ("libnsl" ,libnsl)))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("perl" ,perl)
+       ("pkg-config" ,pkg-config)))
+    (synopsis "Full-featured & secure sendmail replacement")
+    (description "Postfix attempts to be fast, easy to administer, and
+secure.  The outside has a definite Sendmail-ish flavor, but the inside is
+completely different.")
+    (home-page "https://www.postfix.org/")
+    (license license:ibmpl1.0)))
-- 
2.21.0