diff mbox series

[bug#41562] fix tests failing on flowee package

Message ID 5645574.lOV4Wx5bFT@cherry
State Accepted
Headers show
Series [bug#41562] fix tests failing on flowee package | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

guix--- via Guix-patches via May 27, 2020, 11:25 a.m. UTC
The comment to disable it is there, but only one of the two CMake lines that 
enables this test was removed. So now really disable it.
diff mbox series

Patch

From bc9a3faa045579f48804cf42f958409e51cdfbf6 Mon Sep 17 00:00:00 2001
From: TomZ <tomz@freedommail.ch>
Date: Wed, 27 May 2020 13:21:58 +0200
Subject: [PATCH] gnu: flowee: Disable unpredictable test.

* gnu/packages/finance.scm (flowee): The test 'api' has some timeouts
  which fail half the time in a build, so disable the test.
---
 gnu/packages/finance.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index f182057bb4..d176ac0660 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1531,7 +1531,7 @@  like Flowee the Hub, which Fulcrum connects to over RPC.")
          (base32 "1vwvaxm3b71pfx8l4rrv06wqks6xdf2333w856b36s1bzvj53rhc"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags '("-Dbuild_tests=ON" "-Denable_gui=OFF")
+     `(#:configure-flags '("-Dbuild_tests=ON" "-Denable_gui=OFF" "-Denable_gui=false")
        #:phases
         (modify-phases %standard-phases
           (add-before 'configure 'make-qt-deterministic
@@ -1546,6 +1546,8 @@  like Flowee the Hub, which Fulcrum connects to over RPC.")
             (lambda _
               (substitute* "testing/CMakeLists.txt"
                 (("test_api") ""))
+              (substitute* "testing/CMakeLists.txt"
+                (("add_subdirectory\\(api\\)") ""))
               #t))
           (add-after 'configure 'set-build-info
             ;; Their genbuild.sh to generate a build.h fails in guix (no .git dir) .
-- 
2.25.1