[bug#78064,1/1] gnu: Add adw-gtk-theme.

Message ID 56332474183234ba7bb5cf718664d4044fee9e5a.1745607302.git.gabrielsantosdesouza@disroot.org
State New
Headers
Series Add adw-gtk-theme. |

Commit Message

Gabriel Santos April 25, 2025, 6:55 p.m. UTC
  * gnu/packages/gnome-xyz.scm (adw-gtk-theme): New variable.

Change-Id: I8931e066130e57446b2f6c669a9f6842ca8f7c27
---
 gnu/packages/gnome-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: e042751c321b205166b9efa50a56442a7677cb1b
  

Comments

Gabriel Santos April 26, 2025, 5:31 p.m. UTC | #1
There is a 6.0 version now, but it requires dart-sass instead of sassc,
which we don't seem to have packaged.
  

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 5351b043a3..4713e38072 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -25,6 +25,7 @@ 
 ;;; Copyright © 2025 aurtzy <aurtzy@gmail.com>
 ;;; Copyright © 2025 Ashvith Shetty <ashvithshetty0010@zohomail.in>
 ;;; Copyright © 2025 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2025 Gabriel Santos <gabrielsantosdesouza@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -86,6 +87,29 @@  (define-module (gnu packages gnome-xyz)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
+(define-public adw-gtk-theme
+  (package
+    (name "adw-gtk-theme")
+    (version "5.10")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/lassekongo83/adw-gtk3")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "19q180w1f9f35ldvl5r0kqfcxv1jaqf1dni5kfszagpg5f7qrrxi"))))
+    (build-system meson-build-system)
+    (native-inputs (list sassc))
+    (synopsis "Unofficial GTK 3 port of libadwaita")
+    (description
+     "adw is a port of the GTK 4 design for the GTK 3 version.  It enables
+color customization by using the same color names as the ones for
+@code{libadwaita}.")
+    (home-page "https://github.com/lassekongo83/adw-gtk3")
+    (license license:lgpl2.1)))
+
 (define-public arc-icon-theme
   (package
     (name "arc-icon-theme")