diff mbox series

[bug#74522,65/73] move libgl provider from mesa to libglvnd+mesa

Message ID 561ceacf545d13d6f932f70a9e60b0d4029e178c.1732504868.git.squishypinkelephant@gmail.com
State New
Headers show
Series Moving Guix to libglvnd | expand

Commit Message

The Man Nov. 25, 2024, 3:41 a.m. UTC
Change-Id: I023b244e23130a35317c14ffe121a0d5b6b19d99
---
 gnu/packages/webkit.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index b71e7e3e29..4b93ff0609 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -90,7 +90,7 @@  (define-public libwpe
      `(("pkg-config" ,pkg-config)
        ("python" ,python-wrapper)))
     (inputs
-     (list mesa))
+     (list libgl))
     (propagated-inputs
      (list libxkbcommon))
     (synopsis "General-purpose library for WPE")
@@ -116,7 +116,7 @@  (define-public wpebackend-fdo
     (native-inputs
      (list pkg-config))
     (inputs
-     (list glib libepoxy libwpe mesa wayland))
+     (list glib libepoxy libwpe libgl wayland))
     (home-page "https://wpewebkit.org/")
     (synopsis "Wayland WPE backend")
     (description
@@ -267,7 +267,7 @@  (define-public webkitgtk
            libxml2
            libxslt
            libxt
-           mesa
+           libgl
            openjpeg
            sqlite
            woff2