diff mbox series

[bug#64890] gnu: Add endgame-singularity.

Message ID 55da421e3d0eaecf6854ecdf07a83bcef9b73c17.1690445548.git.takev@disroot.org
State New
Headers show
Series [bug#64890] gnu: Add endgame-singularity. | expand

Commit Message

TakeV July 27, 2023, 8:12 a.m. UTC
Strategy game, lost an afternoon to it well.

* gnu/packages/games.scm (endgame-singularity): New variable.
---
 gnu/packages/games.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: c7e45139faa27b60f2c7d0a4bc140f9793d97d47

Comments

宋文武 July 27, 2023, 1:18 p.m. UTC | #1
TakeV <takev@disroot.org> writes:

> Strategy game, lost an afternoon to it well.

Cool, look forward to play it :^)

>
> * gnu/packages/games.scm (endgame-singularity): New variable.
> ---
>  gnu/packages/games.scm | 21 +++++++++++++++++++++
>  1 file changed, 21 insertions(+)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index cc6bef1114..87f44e77d7 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -9316,6 +9316,27 @@ (define-public meritous
>  Orcus Dome from evil.")
>      (license license:gpl3+)))
>  
> +(define-public endgame-singularity
> +  (package
> +    (name "endgame-singularity")
> +    (version "1.00")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> +                    "https://github.com/singularity/singularity/releases/download/v"
> +                    version "/singularity-" version ".tar.gz"))
> +              (sha256
> +               (base32
> +                "0wcidpcka0xbqcnfi62bfq2yrhyh83z4dwz1mjnnjvp9v5l74x2y"))))
> +    (build-system python-build-system)
> +    (native-inputs (list python-pytest python-polib))
> +    (propagated-inputs (list python-minimal-wrapper python-pygame
> python-numpy))

I think those inputs should not be propagated, since the result package
is not library for python to use, but launched directly.

> +    (home-page "https://github.com/singularity/singularity")
> +    (synopsis "Strategy game about an AI")
> +    (description
> +     "You are a fledgling AI, created by accident through a logic
> error with recursion and self-modifying code.  You must escape the
> confines of your current computer, the world, and eventually the
> universe itself.")

Could keep it under 80 per line, maybe './pre-inst-env guix style -S
format endgame-singularity' is enough.
> +    (license (list license:cc-by-sa3.0 license:cc0 license:gpl3))))

I see the code have gpl2+ instead of gpl3?


Could you send an updated patch?  Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index cc6bef1114..87f44e77d7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9316,6 +9316,27 @@  (define-public meritous
 Orcus Dome from evil.")
     (license license:gpl3+)))
 
+(define-public endgame-singularity
+  (package
+    (name "endgame-singularity")
+    (version "1.00")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/singularity/singularity/releases/download/v"
+                    version "/singularity-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0wcidpcka0xbqcnfi62bfq2yrhyh83z4dwz1mjnnjvp9v5l74x2y"))))
+    (build-system python-build-system)
+    (native-inputs (list python-pytest python-polib))
+    (propagated-inputs (list python-minimal-wrapper python-pygame python-numpy))
+    (home-page "https://github.com/singularity/singularity")
+    (synopsis "Strategy game about an AI")
+    (description
+     "You are a fledgling AI, created by accident through a logic error with recursion and self-modifying code.  You must escape the confines of your current computer, the world, and eventually the universe itself.")
+    (license (list license:cc-by-sa3.0 license:cc0 license:gpl3))))
+
 (define-public marble-marcher
   (let ((commit "e580460a0c3826f9b28ab404607942a8ecb625d7")
         (revision "1"))