diff mbox series

[bug#64700] gnu: Add python-core-sr-ht.

Message ID 55c4f6aadd19839a82c6c5f38084377af8896221.1689680115.git.rekado@elephly.net
State New
Headers show
Series [bug#64700] gnu: Add python-core-sr-ht. | expand

Commit Message

Ricardo Wurmus July 18, 2023, 11:35 a.m. UTC
* gnu/packages/sourcehut.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
 gnu/local.mk               |  1 +
 gnu/packages/sourcehut.scm | 81 ++++++++++++++++++++++++++++++++++++++
 2 files changed, 82 insertions(+)
 create mode 100644 gnu/packages/sourcehut.scm


base-commit: 3a3752400d7a70a295a27b66f29457aeeaa2cf27

Comments

Hilton Chain July 19, 2023, 7:07 a.m. UTC | #1
Hi Ricardo!

On Tue, 18 Jul 2023 19:35:16 +0800,
Ricardo Wurmus wrote:
>
> * gnu/packages/sourcehut.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
> ---

Good to know you are packaging sourcehut!

bootstrap is used as a git submodule in "srht/scss/bootstrap" and
would be intalled to the output, so I think it needs to be copied
there.   And I have an origin definition for the version used by
core.sr.ht:
--8<---------------cut here---------------start------------->8---
(let ((name "bootstrap")
      (version "4.1.1"))
  (origin
    (method git-fetch)
    (uri (git-reference
          (url "https://github.com/twbs/bootstrap.git")
          (commit (string-append "v" version))))
    (file-name (git-file-name name version))
    (sha256
     (base32
      "0gl7wd58yhdvwgbc2syd7ci2lz7alaaggnfjzdf9gngmva5gjf6l"))))
--8<---------------cut here---------------end--------------->8---

Then for the package names, how about srht-[...] or sourcehut-[...]?
Just a suggestion, I don't have any good reasons. :-)

Thanks
Ricardo Wurmus July 19, 2023, 9:27 a.m. UTC | #2
Hi,

Hilton Chain <hako@ultrarare.space> writes:

> On Tue, 18 Jul 2023 19:35:16 +0800,
> Ricardo Wurmus wrote:
>>
>> * gnu/packages/sourcehut.scm: New file.
>> * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
>> ---
>
> Good to know you are packaging sourcehut!
>
> bootstrap is used as a git submodule in "srht/scss/bootstrap" and
> would be intalled to the output, so I think it needs to be copied
> there.

I’m fetching it with (recursive? #true) in the git-reference
declaration, so it is already there.

> Then for the package names, how about srht-[...] or sourcehut-[...]?
> Just a suggestion, I don't have any good reasons. :-)

I don’t know.  I just went with our default naming scheme for Python
packages here: “python-” followed by the upstream repository name.
Hilton Chain July 19, 2023, 1:38 p.m. UTC | #3
On Wed, 19 Jul 2023 17:27:55 +0800,
Ricardo Wurmus wrote:
> I’m fetching it with (recursive? #true) in the git-reference
> declaration, so it is already there.

Aaaah!!  Sorry, I skipped than line..

> I don’t know.  I just went with our default naming scheme for Python
> packages here: “python-” followed by the upstream repository name.

FYI, existing names are:

Nix
  - [...]srht
Alpine packages at sr.ht
  - py3-scmsrht
  - py3-srht
  - [...].sr.ht
Arch packages at sr.ht
  - python-scmsrht
  - python-srht
  - [...].sr.ht
Debian packages at sr.ht
  - python3-scmsrht
  - python3-srht
  - python3-[...]srht and srht-[...]

Thanks
Ricardo Wurmus Aug. 1, 2023, 7:44 a.m. UTC | #4
Applied, closing.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 2767f5290b..3196f0241c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -580,6 +580,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/smalltalk.scm			\
   %D%/packages/sml.scm				\
   %D%/packages/solidity.scm			\
+  %D%/packages/sourcehut.scm			\
   %D%/packages/speech.scm			\
   %D%/packages/sphinx.scm			\
   %D%/packages/spice.scm			\
diff --git a/gnu/packages/sourcehut.scm b/gnu/packages/sourcehut.scm
new file mode 100644
index 0000000000..382c357d78
--- /dev/null
+++ b/gnu/packages/sourcehut.scm
@@ -0,0 +1,81 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages sourcehut)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix utils)
+  #:use-module (guix packages)
+  #:use-module (guix gexp)
+  #:use-module (guix git-download)
+  #:use-module (guix build-system pyproject)
+  #:use-module (gnu packages check)
+  #:use-module (gnu packages databases)
+  #:use-module (gnu packages markup)
+  #:use-module (gnu packages monitoring)
+  #:use-module (gnu packages python-build)
+  #:use-module (gnu packages python-check)
+  #:use-module (gnu packages python-crypto)
+  #:use-module (gnu packages python-web)
+  #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages))
+
+(define-public python-core-sr-ht
+  (package
+    (name "python-core-sr-ht")
+    (version "0.69.15")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~sircmpwn/core.sr.ht")
+             (commit version)
+             (recursive? #true)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "00d633lmdiqamyv24szmd441dhkjh1n1qkvf47vn57da0z1rxp2g"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:tests? #false                   ;there are none
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'set-version
+            (lambda _ (setenv "PKGVER" #$version))))))
+    (propagated-inputs
+     (list python-alembic
+           python-beautifulsoup4
+           python-bleach
+           python-celery
+           python-cryptography
+           python-flask
+           python-humanize
+           python-markdown
+           python-mistletoe
+           python-prometheus-client
+           python-psycopg2
+           python-pygments
+           python-redis
+           python-requests
+           python-sqlalchemy
+           python-sqlalchemy-utils))
+    (home-page "https://git.sr.ht/~sircmpwn/core.sr.ht")
+    (synopsis "Shared code for all sourcehut projects")
+    (description
+     "This package contains code shared among all sr.ht projects.")
+    (license license:bsd-3)))