diff mbox series

[bug#55866,1/2] gnu: python-pydevd: Skip tests failing due to YAMA.

Message ID 558bc49a6dba232a5b4bc797b4a034d2e3baf142.1654765434.git.lars@6xq.net
State Accepted
Headers show
Series Disable tests failing due to YAMA’s ptrace_scope. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Lars-Dominik Braun June 9, 2022, 9:04 a.m. UTC
* gnu/packages/python-xyz.scm (python-pydevd)[arguments]: Add skipped
tests.
---
 gnu/packages/python-xyz.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5f9ce4fdfe..8de8d571e4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12351,7 +12351,10 @@  (define-public python-pydevd
                            ;; This test validates that 'pydevd' is not in the
                            ;; exception message, but it is due to being part
                            ;; of the build file name present in the message.
-                           "and not test_evaluate_exception_trace")))))
+                           "and not test_evaluate_exception_trace "
+                           ;; These fail on systems with YAMA LSM’s ptrace
+                           ;; scope > 0.
+                           "and not test_attach_to_pid")))))
             (add-after 'install 'install-attach-binary
               (lambda _
                 (install-file "attach.so"