diff mbox series

[bug#40182,2/2] gnu: Add nextpnr-ice40

Message ID 55875bc483352f8105513ac5006c0666@airmail.cc
State Accepted
Headers show
Series [bug#40182,1/2] gnu: icestorm: Update to latest revision. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job

Commit Message

pinoaffe March 22, 2020, 10:47 a.m. UTC
* gnu/packages/fpga.scm (nextpnr-ice40): New variable.
---
  gnu/packages/fpga.scm | 38 ++++++++++++++++++++++++++++++++++++++
  1 file changed, 38 insertions(+)

    (let ((commit "840bdfdeb38809f9f6af4d89dd7b22959b176fdd")
          (revision "2"))
diff mbox series

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 5cfc9a96f6..8f34ef8282 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -44,6 +44,9 @@ 
    #:use-module (gnu packages gperf)
    #:use-module (gnu packages gawk)
    #:use-module (gnu packages version-control)
+  #:use-module (gnu packages qt)
+  #:use-module (gnu packages boost)
+  #:use-module (gnu packages algebra)
    #:use-module (gnu packages libftdi))

  (define-public abc
@@ -256,6 +259,41 @@  For synthesis, the compiler generates netlists in 
the desired format.")
  Includes the actual FTDI connector.")
      (license license:isc))))

+(define-public nextpnr-ice40
+  (let [(commit "c192ba261d77ad7f0a744fb90b01e4a5b63938c4")
+        (revision "0")]
+  (package
+    (name "nextpnr-ice40")
+    (version (git-version "0.0.0" revision commit))
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "git://github.com/YosysHQ/nextpnr")
+               (commit commit)))
+        (sha256
+          (base32
+            "0g2ar1z89b31qw5vgqj2rrcv9rzncs94184dgcsrz19p866654mf"))))
+    (inputs
+      `(("qtbase" ,qtbase)
+        ("boost" ,boost-with-python3)
+        ("yosys" ,yosys)
+        ("eigen" ,eigen)
+        ("python" ,python)
+        ("icestorm" ,icestorm)))
+    (build-system cmake-build-system)
+    (arguments
+      `(#:configure-flags `("-DARCH=ice40"
+                            ,(string-append "-DICEBOX_ROOT="
+                                            (assoc-ref %build-inputs 
"icestorm")
+                                            "/share/icebox"))
+        #:tests? #f))
+    (synopsis "Place-and-Route tool for FPGAs")
+    (description "nextpnr aims to be a vendor neutral, timing driven,
+FOSS FPGA place and route tool.  ")
+    (home-page "https://github.com/YosysHQ/nextpnr")
+    (license license:expat))))
+
  (define-public arachne-pnr