diff mbox series

[bug#36062] gnu: gpxsee: Upgrade to 7.8

Message ID 555f4e77-d42f-4292-45d3-e05889745818@gmail.com
State Accepted
Headers show
Series [bug#36062] gnu: gpxsee: Upgrade to 7.8 | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Nikolay Korotkiy June 2, 2019, 10:32 p.m. UTC
---
 gnu/packages/gps.scm | 25 +++++++------------------
 1 file changed, 7 insertions(+), 18 deletions(-)

               (uri
@@ -184,7 +184,7 @@ coordinates as well as partial support for
adjustments in global coordinate syst
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "00j0gjldw1kn3i45dppld1pz8r4s1g7lw89k7gfvvqbjjyjih1wg"))))
+                "1k9nbs3knl6s0s4bf1rgrc9lwczawnzm7629igw0zmxb5yka7d9v"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -195,27 +195,16 @@ coordinates as well as partial support for
adjustments in global coordinate syst
              (for-each (lambda (file)
                          (invoke "lrelease" file))
                        (find-files "lang" "\\.ts"))
-             (substitute* "src/config.h"
-               (("/usr/share/gpxsee")
-                (string-append
-                 (assoc-ref outputs "out") "/share/gpxsee")))
              (invoke "qmake"
                      (string-append "PREFIX="
-                                    (assoc-ref outputs "out")))))
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (share (string-append out "/share/gpxsee/")))
-               (install-file "GPXSee" (string-append out "/bin/GPXSee"))
-               (install-file "pkg/maps.txt" share))
-             #t)))))
+                                    (assoc-ref outputs "out"))))))))
     (inputs
      `(("qtbase" ,qtbase)))
     (native-inputs
      `(("qttools" ,qttools)))
-    (home-page "http://www.gpxsee.org")
-    (synopsis "GPX file viewer and analyzer")
+    (home-page "https://www.gpxsee.org")
+    (synopsis "GPS log file viewer and analyzer")
     (description
-     "GPXSee is a Qt-based GPS log file viewer and analyzer that
supports GPX,
-TCX, KML, FIT, IGC and NMEA files.")
+     "GPXSee is a Qt-based GPS log file viewer and analyzer that supports
+all common GPS log file formats.")
     (license license:gpl3)))

Comments

Ludovic Courtès June 13, 2019, 9:02 a.m. UTC | #1
Hi Nikolay,

Nikolay Korotkiy <sikmir@gmail.com> skribis:

> ---
>  gnu/packages/gps.scm | 25 +++++++------------------
>  1 file changed, 7 insertions(+), 18 deletions(-)

I added a commit log following our conventions (see
<https://www.gnu.org/software/guix/manual/en/html_node/Submitting-Patches.html>)
and applied your patch.

Your email client had apparently munged it (it wrapped lines), so I had
to “repair” it, but we’re all set now; you can send it as an attachment
next time or use ‘git send-email’ to make sure it arrives just fine.

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 66e091ddbf..ec45704029 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -175,7 +175,7 @@  coordinates as well as partial support for
adjustments in global coordinate syst
 (define-public gpxsee
   (package
     (name "gpxsee")
-    (version "4.19")
+    (version "7.8")
     (source (origin
               (method url-fetch)