diff mbox series

[bug#70487,core-updates,1/4] gnu: lv2lint: Update to 0.16.2.

Message ID 55416d4cf7cf7172cc2efc898e2cae35ec1dcea3.1713647481.git.poomklao@yahoo.com
State New
Headers show
Series Add more tests to lsp-plugins | expand

Commit Message

Parnikkapore April 20, 2024, 11:02 p.m. UTC
* gnu/packages/audio.scm (lv2lint): Update to 0.16.2.
[configure-flags]: Enable X11 tests, like upstream builds.
[inputs]: Add lv2 and libx11.

Change-Id: Ib331399d8d95117574beab900480885ab4a73fcf
---
 gnu/packages/audio.scm | 17 +++++++++--------
 1 file changed, 9 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 1a88698165..e3a6c692d2 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -45,7 +45,7 @@ 
 ;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
-;;; Copyright © 2023 Parnikkapore <poomklao@yahoo.com>
+;;; Copyright © 2023, 2024 Parnikkapore <poomklao@yahoo.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5733,31 +5733,32 @@  (define-public libaudec
 (define-public lv2lint
   (package
     (name "lv2lint")
-    (version "0.8.0")
+    (version "0.16.2")
     (source
       (origin
         (method git-fetch)
         (uri (git-reference
-               (url "https://git.open-music-kontrollers.ch/lv2/lv2lint")
+               (url "https://git.open-music-kontrollers.ch/~hp/lv2lint")
                (commit version)))
         (file-name (git-file-name name version))
         (sha256
           (base32
-            "1jrka0hsn4n1clri7zfkcl3c2vi52144lkpjm81l51ff8rqy8ks1"))))
+            "0cyiq5amf02k6fkmbch3kgmfx6wa33k310ig7zzf6rwbswmdnk1n"))))
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags
-       `("-Delf-tests=true" ; for checking symbol visibility
-         "-Donline-tests=true"))) ; for checking URI existence
+       `("-Donline-tests=enabled" ; for checking URI existence
+         "-Delf-tests=enabled" ; for checking symbol visibility
+         "-Dx11-tests=enabled"))) ; for checking X11 UI instantiation
     (inputs
-      (list curl libelf lilv))
+      (list lv2 lilv curl libelf libx11))
     (native-inputs
       (list pkg-config))
     (synopsis "LV2 plugin lint tool")
     (description "lv2lint is an LV2 lint-like tool that checks whether a
 given plugin and its UI(s) match up with the provided metadata and adhere
 to well-known best practices.")
-    (home-page "https://open-music-kontrollers.ch/lv2/lv2lint/")
+    (home-page "https://git.open-music-kontrollers.ch/~hp/lv2lint")
     (license license:artistic2.0)))
 
 (define-public lv2toweb