[bug#61065] gnu: Add emacs-ein.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-ein): New variable.
---
gnu/packages/emacs-xyz.scm | 42 ++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)
base-commit: 968b882f55c4d1009e62c603a860edfaee1609ad
Comments
Hello,
Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:
> * gnu/packages/emacs-xyz.scm (emacs-ein): New variable.
Thank you.
> + (propagated-inputs (list emacs-websocket
> + emacs-anaphora
> + emacs-request
> + emacs-deferred
> + emacs-polymode
> + emacs-dash
> + emacs-with-editor))
Could you order propagated inputs alphabetically?
Also, upstream provides tests. Is it feasible to run them, too?
Regards,
@@ -34326,6 +34326,48 @@ (define-public emacs-code-cells
execute code split into cells according to certain magic comments.")
(license license:gpl3+))))
+(define-public emacs-ein
+ (package
+ (name "emacs-ein")
+ (version "20220911")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/millejoh/emacs-ipython-notebook")
+ (commit "b2410dc96f61aa806a7934099d8f1e40c8f6ca18")))
+ (sha256
+ (base32
+ "02392bxl0msda58cls0i79mzqjs73x39czx0mlb0sg2vxp84gy15"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./lisp" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ el-files)))))))
+ (propagated-inputs (list emacs-websocket
+ emacs-anaphora
+ emacs-request
+ emacs-deferred
+ emacs-polymode
+ emacs-dash
+ emacs-with-editor))
+ (home-page "https://github.com/millejoh/emacs-ipython-notebook")
+ (synopsis "Jupyter client for all languages")
+ (description
+ "The Emacs IPython Notebook (EIN) package provides a Jupyter Notebook
+client and integrated REPL (like SLIME) in Emacs. EIN improves notebook
+editing by allowing you to use Emacs. It also expose IPython features such as
+code evaluation, object inspection and code completion. These features can be
+accessed anywhere in Emacs and improve Python code editing and reading in
+general in Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-kibit-helper
(package
(name "emacs-kibit-helper")