[bug#76508] gnu: Add emacs-fpga.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-fpga): New variable.
Change-Id: I43cf987ddb27df9a971535d73e2d76690ddd0ba6
---
I'm packaging here latest commit, as latest release includes a bug and cannot compile.
As soon as a new release comes out, I'll revert to a stable package.
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
base-commit: 0134b8c8d0679ec9b0494ac11a0b5636c2a43807
--
2.48.1
Comments
Hi Cayetano,
Pushed as 48baf572c5.
Thanks,
-- Ian
@@ -153,6 +153,7 @@
;;; Copyright © 2024 Divya Ranjan Pattanaik <divya@subvertising.org>
;;; Copyright © 2025 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2025 Skylar Hill <stellarskylark@posteo.net>
+;;; Copyright © 2025 Cayetano Santos <csantosb@inventati.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42275,6 +42276,29 @@ (define-public emacs-flim-lb
Emacs.")
(license license:gpl2+))))
+(define-public emacs-fpga
+ (let ((commit "7ba64134609cbb9b7a5dd3b960985fa46a582cf0")
+ (revision "0"))
+ (package
+ (name "emacs-fpga")
+ (version (git-version "0.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gmlarumbe/fpga")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0sl3s5bfqmicpg4hp2k6qznrgj71dx0lz3dv2jyd48ys67m9x4dx"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/gmlarumbe/fpga")
+ (synopsis "Emacs fpga & asic utilities")
+ (description
+ "Emacs-fpga provides emacs facilities to interface with fpga & asic
+tools from major vendors.")
+ (license license:gpl3+))))
+
(define-public emacs-semi-epg
;; No release since Dec 24, 2003.
(let ((commit "85a52b899ac89be504d9e38d8d406bba98f4b0b3")