diff mbox series

[bug#68098] gnu: libid3tag: Fix cross-compiling.

Message ID 54a60f22c461db227f40b11f34cbdcfe1363fb31.1703851666.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#68098] gnu: libid3tag: Fix cross-compiling. | expand

Commit Message

Zheng Junjie Dec. 29, 2023, 12:08 p.m. UTC
* gnu/packages/mp3.scm (libid3tag)
[native-inputs]: when cross compiling to {riscv,aarch}64-linux-gnu, add config.
[arguments]: when target {riscv,aarch}64-linux-gnu, add update-config-scripts phase.

Change-Id: I715e20b7d0aeabe7eba76185b542d9d184167448
---
 gnu/packages/mp3.scm | 24 +++++++++++++++++++++++-
 1 file changed, 23 insertions(+), 1 deletion(-)


base-commit: f90d6adec787187f7929159e3327c73245d3bbe3

Comments

Mathieu Othacehe Dec. 29, 2023, 5:11 p.m. UTC | #1
Hello,

> +        ,@(if (and (%current-target-system)
> +                   (or (target-riscv64?)
> +                       (target-aarch64?)))
> +              `((add-after 'unpack
> +                    'update-config
> +                  (lambda* (#:key native-inputs inputs
> +                            #:allow-other-keys)
> +                    (for-each
> +                     (lambda (file)
> +                       (install-file
> +                        (search-input-file
> +                         (or native-inputs inputs)
> +                         (string-append
> +                          "/bin/" file)) "."))
> +                     '("config.guess" "config.sub")))))
> +              '()))))

It is important to stay below the 78 columns limit but, going the other
direction decreases the readability. I joined a few lines before
applying.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 7ede16f4bb..67b1528a7f 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -161,7 +162,28 @@  (define-public libid3tag
                            Version: ~a~@
                            Libs: -L${libdir} -lid3tag -lz~@
                            Cflags: -I${includedir}~%"
-                          out ,version)))))))))
+                          out ,version))))))
+        ,@(if (and (%current-target-system)
+                   (or (target-riscv64?)
+                       (target-aarch64?)))
+              `((add-after 'unpack
+                    'update-config
+                  (lambda* (#:key native-inputs inputs
+                            #:allow-other-keys)
+                    (for-each
+                     (lambda (file)
+                       (install-file
+                        (search-input-file
+                         (or native-inputs inputs)
+                         (string-append
+                          "/bin/" file)) "."))
+                     '("config.guess" "config.sub")))))
+              '()))))
+   (native-inputs (if (and (%current-target-system)
+                           (or (target-riscv64?)
+                               (target-aarch64?)))
+                      (list config)
+                      '()))
    (inputs (list zlib))
    (synopsis "Library for reading ID3 tags")
    (description