[bug#76746,06/13] gnu: Add python-jaconv.

Message ID 54961c3cfca0cf261d3b3862584ba365e9ae7469.1741114923.git.45mg.writes@gmail.com
State New
Headers
Series Add spotify-downloader. |

Commit Message

45mg March 4, 2025, 7:13 p.m. UTC
  * gnu/packages/python-xyz.scm (python-jaconv): New variable.

Change-Id: I0b29cd00f311ae2a4dbb2c8f59148fc4bbadc144
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 22db4d8b45..cec76daa24 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34460,6 +34460,28 @@  (define-public python-flufl-i18n
 different tasks.")
     (license license:asl2.0)))
 
+(define-public python-jaconv
+  (package
+    (name "python-jaconv")
+    (version "0.3.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ikegami-yukino/jaconv")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1pfx0zvyz07c1jywrv5ayklpmjz91mrb62gc52g48d4qnqwa3fzn"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pytest python-setuptools python-wheel))
+    (home-page "https://github.com/ikegami-yukino/jaconv")
+    (synopsis "Python Japanese character interconverter")
+    (description
+     "@code{jaconv} (Japanese Converter) is an interconverter for Hiragana,
+Katakana, Hankaku (half-width character) and Zenkaku (full-width character)")
+    (license license:expat)))
+
 (define-public python-flufl-lock
   (package
     (name "python-flufl-lock")