diff mbox series

[bug#40064] Resubmission of patch for Package Description for CRAN Package r-crochet

Message ID 54793c0b-ca82-e80c-1da6-b06ea709b091@riseup.net
State Accepted
Headers show
Series [bug#40064] Resubmission of patch for Package Description for CRAN Package r-crochet | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Naga Malleswari March 14, 2020, 6:16 p.m. UTC
Hi

I am resubmitting with the new patch file for CRAN Package Description 
r-crochet.

Hope it's the correct way which i was following.


Through put the process,I have doubt in lint.

when i run it , it's showing the error continuously like this with 
different codes.

guix/build/download.scm:313:6: In procedure tls-wrap:
X.509 certificate of 'www.x.org' could not be verified:
   signer-not-found
   invalid

Comments

ashish.is--- via Guix-patches" via March 14, 2020, 10:41 p.m. UTC | #1
Hullo Naga,

Naga Malleswari 写道:
> I am resubmitting with the new patch file for CRAN Package 
> Description 
> r-crochet.

Thank you!

> Hope it's the correct way which i was following.

Sending a patch to guix-patches@gnu.org will always create a new 
bug number[0].  In this case, you don't want that to happen.

The way to submit a revised patch is to send it to the previous 
bug number (nnnnn@debbugs.gnu.org, in this case 
40040@debbugs.gnu.org) and clearly mark it as a new revision (V2, 
V3, &c.).

If, like me, you use git send-email, this is easy:

  ~/guix $ git send-email --to=40040@debbugs.gnu.org -v2 -1

I've merged the two duplicate bug numbers for this package.

Kind regards,

T G-R

[0]: 
https://debbugs.gnu.org/cgi/pkgreport.cgi?package=guix-patches;include=subject%3Ar-crochet
Naga Malli CH March 15, 2020, 12:33 p.m. UTC | #2
On Sun, 15 Mar 2020 at 04:11, Tobias Geerinckx-Rice via Guix-patches via <
guix-patches@gnu.org> wrote:

> Hullo Naga,
>
> Naga Malleswari 写道:
> > I am resubmitting with the new patch file for CRAN Package
> > Description
> > r-crochet.
>
> Thank you!



You are Welcome

>
> > Hope it's the correct way which i was following.
>
> Sending a patch to guix-patches@gnu.org will always create a new
> bug number[0].  In this case, you don't want that to happen.
>
> The way to submit a revised patch is to send it to the previous
> bug number (nnnnn@debbugs.gnu.org, in this case
> 40040@debbugs.gnu.org) and clearly mark it as a new revision (V2,
> V3, &c.).
>
> If, like me, you use git send-email, this is easy:
>
>   ~/guix $ git send-email --to=40040@debbugs.gnu.org -v2 -1
>
> I've merged the two duplicate bug numbers for this package.
>
> Sure,I will do that from next time Onwards.


> Kind regards,
>
> T G-R
>
> [0]:
>
> https://debbugs.gnu.org/cgi/pkgreport.cgi?package=guix-patches;include=subject%3Ar-crochet




Can I Now the status of my patch ? Can you please advice me here about the
further process i have to do to reach the contribution?
Danny Milosavljevic March 17, 2020, 9:50 a.m. UTC | #3
Hi,

there's a whitespace error at the bottom of the patch.  When I try to apply it
using "git am" I immediately get a warning message.

Also, the subject you used "gnu: r-crochet: New variable" would mean that
you add a new variable inside r-chochet, which you don't.

It should be: "gnu: Add r-crochet".

and

"* gnu/packages/cran.scm (r-crochet): New variable.".

Please examine some other commit messages in guix master for a template.

I've invoked guix lint and I get:

gnu/packages/cran.scm:20813:6: r-crochet@2.2.0: use @code or similar ornament instead of quotes
/home/dannym/src/guix-r/guix/gnu/packages/cran.scm:20814:0: r-crochet@2.2.0: trailing white space on line 20814
/home/dannym/src/guix-r/guix/gnu/packages/cran.scm:20815:0: r-crochet@2.2.0: trailing white space on line 20815

Could you fix these problems and submit a new version (v3) of the patch
(using git send-email --to=40040@debbugs.gnu.org , for example)?
diff mbox series

Patch

From 873d609cb823422c4658c3070ef727911ff45a85 Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Sat, 14 Mar 2020 21:46:26 +0530
Subject: [PATCH]  gnu: r-crochet: New variable.

        * gnu/packages/cran.scm (r-crochet): Added a New Package Description.
---
 gnu/packages/cran.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 406ccc644b..b51862a3ab 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20794,3 +20794,24 @@  statistics and p-values of the correlation coefficients.")
 scales and utilities, including a spell check function for plot label fields
 and an overall emphasis on typography.")
     (license license:expat)))
+
+(define-public r-crochet
+  (package
+    (name "r-crochet")
+    (version "2.2.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "crochet" version))
+        (sha256
+          (base32
+            "1cbv79nyycxk6f8ldcsnn2pvgxqlnrj0qs19nhafnq2clxy863k6"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/agrueneberg/crochet")
+    (synopsis "Implementation Helper for '[' and '[<-' of Custom Matrix-Like Types")
+    (description
+      "Functions to help implement the extraction / subsetting /
+indexing function '[' and replacement function '[<-' of custom matrix-like 
+types (based on S3, S4, etc.), modeled as closely to the base matrix class 
+as possible (with tests to prove it).")
+    (license license:expat)))
-- 
2.20.1