diff mbox series

[bug#64221,2/2] gnu: aerc: Update to 0.15.2

Message ID 546cc2ac9728c053f0dc5c25de6997a263ad0359.1687427674.git.mcsinyx@disroot.org
State New
Headers show
Series gnu: Update aerc to 0.15.2 | expand

Commit Message

Deslauriers, Douglas via Guix-patches" via June 22, 2023, 9:55 a.m. UTC
* gnu/packaging/mail.scm (aerc): Update to 0.15.2.

Signed-off-by: Nguyễn Gia Phong <mcsinyx@disroot.org>
---
 gnu/packages/mail.scm | 19 ++++++++++++-------
 1 file changed, 12 insertions(+), 7 deletions(-)

Comments

Deslauriers, Douglas via Guix-patches" via June 22, 2023, 10:05 a.m. UTC | #1
I should have checked the manual again before running git send-email.
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 801555803af9..d88576d1f139 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4855,7 +4855,7 @@  (define-public smtpmail
 (define-public aerc
   (package
     (name "aerc")
-    (version "0.14.0")
+    (version "0.15.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -4864,17 +4864,20 @@  (define-public aerc
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "067j7kja78hv7dafw8gy3m2g5cslq6xlnzja8lm3b5p0m0vfabm8"))))
+                "1gbprx0i8d13q974n5hsys6lllav5cpll3cwrr1hfw6307hc001r"))))
     (build-system go-build-system)
     (arguments
      (list #:import-path "git.sr.ht/~rjarry/aerc"
            ;; Installing the source is only necessary for Go libraries.
            #:install-source? #f
            #:build-flags
-           #~(list "-tags=notmuch" "-ldflags"
-                   (string-append "-X main.Version=" #$version
-                                  " -X git.sr.ht/~rjarry/aerc/config.shareDir="
-                                  #$output "/share/aerc"))
+           #~(list "-tags=notmuch"
+                   (string-append
+                     "-ldflags=-X main.Version=" #$version
+                     " -X git.sr.ht/~rjarry/aerc/config.libexecDir="
+                     #$output "/libexec/aerc"
+                     " -X git.sr.ht/~rjarry/aerc/config.shareDir="
+                     #$output "/share/aerc"))
            #:phases
            #~(modify-phases %standard-phases
                (add-after 'unpack 'patch-paths
@@ -4912,7 +4915,7 @@  (define-public aerc
                            (string-append "src/" import-path))))
                (replace 'install
                  (lambda* (#:key import-path build-flags #:allow-other-keys)
-                   (invoke "make" "install" "-C"
+                   (invoke "make" "CC=gcc" "install" "-C"
                            (string-append "src/" import-path)
                            (string-append "PREFIX=" #$output)))))))
     (inputs (list gnupg
@@ -4951,6 +4954,8 @@  (define-public aerc
                   go-github-com-syndtr-goleveldb-leveldb
                   go-git-sr-ht-sircmpwn-getopt
                   go-git-sr-ht-rockorager-tcell-term
+                  python
+                  python-vobject
                   zoxide))
     (native-inputs (list scdoc))
     (home-page "https://git.sr.ht/~rjarry/aerc")