diff mbox series

[bug#38689] gnu: Add vl1-emulator

Message ID 543f4f865442829c576d5e8c9b3dd480043d323d.camel@zrythm.org
State Accepted
Headers show
Series [bug#38689] gnu: Add vl1-emulator | expand

Commit Message

Alexandros Theodotou Dec. 20, 2019, 3:30 p.m. UTC
Fixed the wrong home page
diff mbox series

Patch

From 13f4dcdc8f2395d9899e3393984474bf7333614c Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 20 Dec 2019 15:20:20 +0000
Subject: [PATCH] gnu: Add vl1-emulator.

* gnu/packages/music.scm (vl1-emulator): New variable.
---
 gnu/packages/music.scm | 44 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f80fb067e8..b8b844e6fd 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5106,3 +5106,47 @@  MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
     (description "Helm is a cross-platform polyphonic synthesizer available standalone
 and as an LV2 plugin.")
     (license license:gpl3+)))
+
+(define-public vl1-emulator
+  (package
+    (name "vl1-emulator")
+    (version "0.0.0-1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/linuxmao-org/VL1-emulator.git")
+               (commit "defa85fea1574cea81cbe53a6ab4061a4a9a089e")
+               (recursive? #t))) ; for the DISTRHO plugin framework
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "1k5ig72silah5m9lnqwkn49hwkni1zkpz4y1nvnkg2a2ycwfqz53"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; no check target
+       #:make-flags
+       (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+             (string-append "PREFIX="))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'set-CC-variable
+           (lambda _
+             (setenv "CC" "gcc")))
+         ;; no configure script
+         (delete 'configure))))
+    (inputs
+     `(("cairo" ,cairo)
+       ("jack" ,jack-1)
+       ("mesa" ,mesa)
+       ("libx11" ,libx11)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("lv2" ,lv2)))
+    (home-page "https://github.com/linuxmao-org/VL1-emulator")
+    (synopsis "Emulator of Casio VL-Tone VL1")
+    (description
+     "An emulator of Casio VL-Tone VL1, based on source code by PolyValens,
+offered as an LV2 plugin and a standalone JACK application.")
+    ;; Expat or CC0
+    (license (list license:expat license:cc0))))
-- 
2.24.1