diff mbox series

[bug#67010,1/2] gnu: icedtea-8: Fix building on powerpc-linux.

Message ID 54189ddc01c58bc613053c8df1eb02d6c28325fd.1699511272.git.efraim@flashner.co.il
State New
Headers show
Series icedtea-8 powerpc-linux patches | expand

Commit Message

Efraim Flashner Nov. 9, 2023, 6:41 a.m. UTC
* gnu/packages/java.scm (icedtea-8)[arguments]: When building for
powerpc-linux add a configure-flag to skip the java flight recorder.

Change-Id: I3b9e137c82766507c46ba7a54dff64c3c50c3685
---

I wasn't able to find a way to add this without changing the hash for
the other architectures. Also, I think this is also true for armhf, but
currently jamvm doesn't build for that architecture so I couldn't test
it.

 gnu/packages/java.scm | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index ac427b8eaa..99c8839803 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -738,6 +738,10 @@  (define-public icedtea-8
                    "--enable-nss"
                    ,(string-append "--with-parallel-jobs="
                                    (number->string (parallel-job-count)))
+                   ;; Java Flight Recorder isn't supported on some architectures.
+                   ,@(if ,(target-ppc32?)
+                       `("--enable-jfr=no")
+                       '())
                    "--disable-downloading"
                    "--disable-system-pcsc"
                    "--disable-system-sctp"