diff mbox series

[bug#40782] new package; hexer

Message ID 5401348.DvuYhMxLoT@peach
State Accepted
Headers show
Series [bug#40782] new package; hexer | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

guix--- via Guix-patches via April 22, 2020, 8:38 p.m. UTC
This is a text editor for binary files, please let me know if you are Ok with 
the file I picked for it.

Comments

Brice Waegeneire May 1, 2020, 5:05 p.m. UTC | #1
Hello Tom,

Thank you for the patch!

There a few minor thing to adjust from your patch:
1. Add your copyright at the top of the file.
2. End your git title and message lines with a colon.
2. Use the latest version of the package, 1.0.6.
3. Keep the description line under 80 character.
4. Add a comment about why the tests are disabled, in our case
    there is no test suite.

  Cheers,
  - Brice
Kyle Meyer May 1, 2020, 10:55 p.m. UTC | #2
Brice Waegeneire writes:

> 2. End your git title and message lines with a colon.

s/colon/period/ :)
Brice Waegeneire May 6, 2020, 9:14 a.m. UTC | #3
Pushed as 8b95f741353248c19a5d70dc19e311ed059143f3.
diff mbox series

Patch

From 2c0ba963679e37f444094ec4b5f21160d27ab361 Mon Sep 17 00:00:00 2001
From: TomZ <tomz@freedommail.ch>
Date: Wed, 22 Apr 2020 22:31:03 +0200
Subject: [PATCH] gnu: Add hexer

* gnu/packages/text-editors.scm (hexer): New Variable
---
 gnu/packages/text-editors.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 36571e7846..9af3b15f8d 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -967,3 +967,35 @@  keybindings, autocomplete and unlimited undo.  It can pipe a marked block
 of text through any command line filter.  It can also open very large binary
 files.  It was originally developed on the Amiga 3000T.")
     (license license:gpl3+)))
+
+(define-public hexer
+  (package
+    (name "hexer")
+    (version "1.0.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://devel.ringlet.net/files/editors/hexer/"
+                            "hexer-" version ".tar.xz"))
+        (sha256
+          (base32 "14ap9zmwya9m8v896jdvjkbv234yl8w9wfa4apyfh14vcgjkb8rr"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f
+       #:make-flags
+       (list "CC=gcc"
+             (string-append "PREFIX=" (assoc-ref %outputs "out"))
+             (string-append "LTERMCAP=-lncurses")
+             (string-append "LDFLAGS=-L" (assoc-ref %build-inputs "ncurses")
+                            "/lib"))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))            ;no configure script
+    (inputs
+     `(("ncurses" ,ncurses)))
+    (home-page "https://devel.ringlet.net/editors/hexer/")
+    (synopsis "Multi buffer editor for binary files with vi-like interface")
+    (description "Hexer is a multi-buffer editor for binary files for Unix-like systems
+that displays its buffer(s) as a hex dump.  The user interface is kept
+similar to vi/ex.")
+    (license license:bsd-3)))
-- 
2.26.2