diff mbox series

[bug#69309] gnu: Add libpg_query

Message ID 53f7322718138c68263c55aeffb787b316fbfdf0.1708613702.git.marc@mccd.space
State New
Headers show
Series [bug#69309] gnu: Add libpg_query | expand

Commit Message

Marc Coquand Feb. 22, 2024, 2:55 p.m. UTC
* gnu/packages/libpg_query.scm

The name of the library is libpg_query, so it has not been renamed
to use hyphen despite the linters complaints.

There is also a warning: No valid tags found that I have been unable
to resolve.

Change-Id: I7fff485880397cfe1d0b9e7c5beb835882454cd2
Signed-off-by: Marc Coquand <marc@mccd.space>
---
 gnu/packages/libpg_query.scm | 64 ++++++++++++++++++++++++++++++++++++
 1 file changed, 64 insertions(+)
 create mode 100644 gnu/packages/libpg_query.scm


base-commit: fdbf4192f5eaa7fdb5e6e2e98ada0726c8104824
diff mbox series

Patch

diff --git a/gnu/packages/libpg_query.scm b/gnu/packages/libpg_query.scm
new file mode 100644
index 0000000000..f80ed4827a
--- /dev/null
+++ b/gnu/packages/libpg_query.scm
@@ -0,0 +1,64 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Marc Coquand <marc@mccd.space>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages libpg_query)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages base)
+  #:use-module (gnu packages commencement)
+  #:use-module (guix packages)
+  #:use-module (guix git-download)
+  #:use-module (guix utils)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module ((guix licenses) #:prefix license:)
+ )
+
+(define-public libpg_query
+  (package
+    (name "libpg_query")
+    (version "16-5.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pganalyze/libpg_query")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0wk39vx3pbq19s89qh5k4a45hdnpm6c476sbq4w0g430ly6313sz"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (delete 'configure)
+                  (delete 'check)
+                  (add-before 'build 'set-additional-paths
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (setenv "CC" "gcc")
+                      (substitute* "Makefile"
+                        (("prefix = /usr/local")
+                         (string-append "prefix="
+                                        (assoc-ref %outputs "out")))))))))
+    (inputs (list which gcc-toolchain))
+    (home-page "https://github.com/pganalyze/libpg_query")
+    (synopsis
+     "C library for accessing the PostgreSQL parser outside of the server environment")
+    (description
+     "C library for accessing the PostgreSQL parser outside of the server.
+This library uses the actual PostgreSQL server source to parse SQL queries
+ and return the internal PostgreSQL parse tree.")
+    (license license:bsd-3)))