[bug#75539] gnu: sbcl-dbus: Update to 20231105-1.8bba6a09

Message ID 539afd690076238180d2422fd68e9262dfc65d2d.1736775510.git.dk@junkeria.club
State New
Headers
Series [bug#75539] gnu: sbcl-dbus: Update to 20231105-1.8bba6a09 |

Commit Message

Junker Jan. 13, 2025, 5:42 p.m. UTC
  Change-Id: I7bce4b64a389d58dfe56fb7e888e0a53a75cb153
---
 gnu/packages/lisp-xyz.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)


base-commit: 9edb4fe373893becde2ce3e6703b33093fd0b04a
  

Comments

Junker Jan. 18, 2025, 10:47 a.m. UTC | #1
This is my first patch, and I would appreciate any feedback you might have.
  
Nicolas Graves Jan. 18, 2025, 2:23 p.m. UTC | #2
On 2025-01-18 13:47, Junker wrote:

> This is my first patch, and I would appreciate any feedback you might
> have.

When you send patches once again, don't forget a -v2 flag ;)

Not familiar with CL, but the package builds fine, and the only lint is
a warning.  Looks good to me ;)

Welcome!
  
Nicolas Graves Jan. 18, 2025, 2:31 p.m. UTC | #3
On 2025-01-18 15:23, Nicolas Graves wrote:

> On 2025-01-18 13:47, Junker wrote:
>
>> This is my first patch, and I would appreciate any feedback you might
>> have.
>
> When you send patches once again, don't forget a -v2 flag ;)
>
> Not familiar with CL, but the package builds fine, and the only lint is
> a warning.  Looks good to me ;)
>
> Welcome!

Sorry, you also forgot to add the description of you changes.  It
usually starts at line 3.  You can see more about that at :

https://www.gnu.org/prep/standards/html_node/Change-Logs.html

For instance, on a recent commit: 

* gnu/packages/dictionaries.scm (gcide): Update to 0.54.

If you use emacs, there are some yasnippets or tempel snippets you can
use, in guix's source etc directory.
  
Sharlatan Hellseher Feb. 4, 2025, 2:45 p.m. UTC | #4
Hi,

Pushed to master as

96a8a41f608 * master gnu: sbcl-dbus: Update to 20231105-2.8bba6a09.

--
Oleg
  

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0e799e1a8e..8f9c4af1df 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13600,11 +13600,11 @@  (define-public ecl-dbi
   (sbcl-package->ecl-package sbcl-dbi))
 
 (define-public sbcl-dbus
-  (let ((commit "24b452df3a45ca5dc95015500f34baad175c981a")
+  (let ((commit "8bba6a0942232e9d7fa915b33bbe32dfedc5abb9")
         (revision "1"))
     (package
       (name "sbcl-dbus")
-      (version (git-version "20190408" revision commit))
+      (version (git-version "20231105" revision commit))
       (home-page "https://github.com/death/dbus")
       (source
        (origin
@@ -13615,7 +13615,7 @@  (define-public sbcl-dbus
          (file-name (git-file-name name version))
          (sha256
           (base32
-           "0fw2q866yddbf23nk9pxphm9gsasx35vjyss82xzvndnjmzlqfl5"))))
+           "1y880074m9g0swxrzpbplmkdxc6r62gzyigglf4x2i0zyss3gf65"))))
       (build-system asdf-build-system/sbcl)
       (inputs
        (list sbcl-alexandria