diff mbox series

[bug#68173] gnu: Add morris.

Message ID 538fccb4a1bc4005b85b43a168873abea5e95d42.1704028653.git.w@wmeyer.eu
State New
Headers show
Series [bug#68173] gnu: Add morris. | expand

Commit Message

Wilko Meyer Dec. 31, 2023, 1:17 p.m. UTC
* gnu/packages/games.scm (morris): New variable.

Change-Id: I35158d1f5cfd5f7267dcb8295d8102e2dd3f575c
---
 gnu/packages/games.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: f24b14767d362a84e6469682b4fe303b50f4b589
prerequisite-patch-id: b3c8c2f810e3581b22e34e6852353ebb505fa020

Comments

Liliana Marie Prikler Jan. 14, 2024, 12:05 p.m. UTC | #1
Am Sonntag, dem 31.12.2023 um 14:17 +0100 schrieb Wilko Meyer:
> * gnu/packages/games.scm (morris): New variable.
> 
> Change-Id: I35158d1f5cfd5f7267dcb8295d8102e2dd3f575c
> ---
Hi, this patch fails to apply both locally and on CI.  Can you rebase
this on your side and reroll?

Cheers
Wilko Meyer Jan. 14, 2024, 12:46 p.m. UTC | #2
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Sonntag, dem 31.12.2023 um 14:17 +0100 schrieb Wilko Meyer:
>> * gnu/packages/games.scm (morris): New variable.
>> 
>> Change-Id: I35158d1f5cfd5f7267dcb8295d8102e2dd3f575c
>> ---
> Hi, this patch fails to apply both locally and on CI.  Can you rebase
> this on your side and reroll?
>
> Cheers

Thanks for getting back to this! While preparing to do so I noticed:

(guix230 (~/devel/guix_proper)) λ git blame -L :morris gnu/packages/games.scm    
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10509) (define-public morris
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10510)   (package
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10511)     (name "morris")
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10512)     (version "0.3")
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10513)     (source
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10514)      (origin
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10515)        (method git-fetch)
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10516)        (uri (git-reference
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10517)              (url "https://github.com/farindk/morris")
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10518)              (commit (string-append "v" version))))
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10519)        (file-name (git-file-name name version))
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10520)        (sha256
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10521)         (base32 "1kkcnpkzgybm7rqg7nafd7sqd5m4alns6l4j5zcf3p41jdc9s3iv"))))
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10522)     (build-system glib-or-gtk-build-system)
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10523)     (inputs (list automake autoconf pkg-config intltool
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10524)                gnu-gettext libtool glib gtk+-2 boost))
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10525)     (arguments `(#:tests? #f))
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10526)     (home-page "http://nine-mens-morris.net/downloads.html")
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10527)     (synopsis "Morris is an implementation of the board game Nine Men's Morris")
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10528)     (description "Morris is an implementation of the board game Nine Men's Morris.
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10529) It supports not only the standard game, but also several rule-variants and different
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10530) board layouts. You can play against the computer, or simply use the program to
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10531) present the board, but play against another human opponent.")
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10532)     (license license:gpl3)))
11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10533) 

that the changes are already present and have been applied on
master[0]. I guess rebasing and resending an already applied patch isn't
feasible. Let me know if there's still work required on my side.

[0]: https://git.savannah.gnu.org/cgit/guix.git/commit/?id=11136fb0ad90937516ce0421a352e3a4513fca3b
Liliana Marie Prikler Jan. 14, 2024, 1:16 p.m. UTC | #3
Am Sonntag, dem 14.01.2024 um 13:46 +0100 schrieb Wilko Meyer:
> 
> Hi Liliana,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > Am Sonntag, dem 31.12.2023 um 14:17 +0100 schrieb Wilko Meyer:
> > > * gnu/packages/games.scm (morris): New variable.
> > > 
> > > Change-Id: I35158d1f5cfd5f7267dcb8295d8102e2dd3f575c
> > > ---
> > Hi, this patch fails to apply both locally and on CI.  Can you
> > rebase this on your side and reroll?
> > 
> > Cheers
> 
> Thanks for getting back to this! While preparing to do so I noticed:
> 
> (guix230 (~/devel/guix_proper)) λ git blame -L :morris
> gnu/packages/games.scm    
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10509) (define-
> public morris
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10510)   (package
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10511)     (name
> "morris")
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10512)    
> (version "0.3")
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10513)     (source
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10514)     
> (origin
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10515)       
> (method git-fetch)
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10516)        (uri
> (git-reference
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100
> 10517)              (url "https://github.com/farindk/morris")
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100
> 10518)              (commit (string-append "v" version))))
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10519)       
> (file-name (git-file-name name version))
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10520)       
> (sha256
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10521)        
> (base32 "1kkcnpkzgybm7rqg7nafd7sqd5m4alns6l4j5zcf3p41jdc9s3iv"))))
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10522)     (build-
> system glib-or-gtk-build-system)
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10523)     (inputs
> (list automake autoconf pkg-config intltool
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100
> 10524)                gnu-gettext libtool glib gtk+-2 boost))
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10525)    
> (arguments `(#:tests? #f))
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10526)     (home-
> page "http://nine-mens-morris.net/downloads.html")
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10527)    
> (synopsis "Morris is an implementation of the board game Nine Men's
> Morris")
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10528)    
> (description "Morris is an implementation of the board game Nine
> Men's Morris.
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10529) It supports
> not only the standard game, but also several rule-variants and
> different
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10530) board
> layouts. You can play against the computer, or simply use the program
> to
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10531) present the
> board, but play against another human opponent.")
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10532)    
> (license license:gpl3)))
> 11136fb0ad9 (Wilko Meyer 2023-12-31 14:17:33 +0100 10533) 
> 
> that the changes are already present and have been applied on
> master[0]. I guess rebasing and resending an already applied patch
> isn't feasible. Let me know if there's still work required on my
> side.
In that case, someone already pushed it without noticing the ML. 
Closing then.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1e203af9d1d..fbca9b60815 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10446,6 +10446,31 @@  (define-public moonfish
 using any UCI engine and also to connect UCI engines to Lichess.")
       (license license:agpl3+))))
 
+(define-public morris
+  (package
+    (name "morris")
+    (version "0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/farindk/morris")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1kkcnpkzgybm7rqg7nafd7sqd5m4alns6l4j5zcf3p41jdc9s3iv"))))
+    (build-system glib-or-gtk-build-system)
+    (inputs (list automake autoconf pkg-config intltool
+		 gnu-gettext libtool glib gtk+-2 boost))
+    (arguments `(#:tests? #f))
+    (home-page "http://nine-mens-morris.net/downloads.html")
+    (synopsis "Morris is an implementation of the board game Nine Men's Morris")
+    (description "Morris is an implementation of the board game Nine Men's Morris.
+It supports not only the standard game, but also several rule-variants and different
+board layouts. You can play against the computer, or simply use the program to
+present the board, but play against another human opponent.")
+    (license license:gpl3)))
+
 (define-public barrage
   (package
     (name "barrage")