diff mbox series

[bug#73374] gnu: pam-mount: fix libcryptsetup detection

Message ID 538b17f2-ba69-4f54-9f6d-b431c1a7f137@nborghese.com
State New
Headers show
Series [bug#73374] gnu: pam-mount: fix libcryptsetup detection | expand

Commit Message

nathan Sept. 20, 2024, 2:43 a.m. UTC
easy way to test:
look at the configure log and observe that it's detected now.

Comments

Oleg Pykhalov Nov. 1, 2024, 4:05 p.m. UTC | #1
Hi Nikita,

Apologize for the delay in response.

Thank you for updating the patch!

Nikita Domnitskii <nikita@domnitskii.me> writes:

> Unified commits that are deleting and adding inputs. Removed lib output
> of `util-linux` because it's already provided by
> `libcryptsetup-propagated-inputs`
>
> Nikita Domnitskii (1):
>   gnu: pam-mount: Update to 2.20.
>
> nathan via Guix-patches via (1):
>   gnu: pam-mount: Fix libcryptsetup detection.
>
>  gnu/packages/admin.scm | 31 +++++++++++++++++--------------
>  1 file changed, 17 insertions(+), 14 deletions(-)
>
>
> base-commit: 657919afa46f562d7540495b2a22a0617202cafc

Pushed as cd9ac7d96b3634a7e1ec8da988dd3ac2dd186018 to master.


Regards,
Oleg.
diff mbox series

Patch

From b3d6cc85ddcbfb162f679a6f59086b7825b1a712 Mon Sep 17 00:00:00 2001
Message-ID: <b3d6cc85ddcbfb162f679a6f59086b7825b1a712.1726799784.git.nathan_mail@nborghese.com>
From: nathan <nathan_mail@nborghese.com>
Date: Thu, 19 Sep 2024 22:27:53 -0400
Subject: [PATCH] gnu: pam-mount: fix libcryptsetup detection

* gnu/packages/admin.scm (pam-mount): Fix libcryptsetup detection
[inputs]: Add extra inputs required for libcryptsetup
[arguments]<#:configure-flags>: Explicitly enable cryptsetup in order to
detect breakage in the future

Change-Id: Icf588945279c8785081a8049d401eaf7e6a22e3c
---
 gnu/packages/admin.scm | 22 ++++++++++++----------
 1 file changed, 12 insertions(+), 10 deletions(-)

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 4910327d99..f8552c69ce 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4936,7 +4936,8 @@  (define-public pam-mount
      (list
       #:configure-flags
       #~(list (string-append "--with-slibdir=" #$output "/lib")
-              (string-append "--with-ssbindir=" #$output "/sbin"))
+              (string-append "--with-ssbindir=" #$output "/sbin")
+              "--with-cryptsetup")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'patch-file-names
@@ -4965,15 +4966,16 @@  (define-public pam-mount
     (native-inputs
      (list perl pkg-config))
     (inputs
-     (list cryptsetup
-           libhx
-           libxml2
-           linux-pam
-           lvm2
-           openssl
-           pcre2
-           `(,util-linux "lib")
-           util-linux))
+     (append
+      (cons* cryptsetup eudev (libcryptsetup-propagated-inputs))
+      (list libhx
+            libxml2
+            linux-pam
+            lvm2
+            openssl
+            pcre2
+            `(,util-linux "lib")
+            util-linux)))
     (home-page "https://inai.de/projects/pam_mount/")
     (synopsis "PAM module to mount volumes for a user session")
     (description

base-commit: 6ea75bb9bcc52521f0bb3f121799745fdc17f1c9
-- 
2.46.0