From b3d6cc85ddcbfb162f679a6f59086b7825b1a712 Mon Sep 17 00:00:00 2001
Message-ID: <b3d6cc85ddcbfb162f679a6f59086b7825b1a712.1726799784.git.nathan_mail@nborghese.com>
From: nathan <nathan_mail@nborghese.com>
Date: Thu, 19 Sep 2024 22:27:53 -0400
Subject: [PATCH] gnu: pam-mount: fix libcryptsetup detection
* gnu/packages/admin.scm (pam-mount): Fix libcryptsetup detection
[inputs]: Add extra inputs required for libcryptsetup
[arguments]<#:configure-flags>: Explicitly enable cryptsetup in order to
detect breakage in the future
Change-Id: Icf588945279c8785081a8049d401eaf7e6a22e3c
---
gnu/packages/admin.scm | 22 ++++++++++++----------
1 file changed, 12 insertions(+), 10 deletions(-)
@@ -4936,7 +4936,8 @@ (define-public pam-mount
(list
#:configure-flags
#~(list (string-append "--with-slibdir=" #$output "/lib")
- (string-append "--with-ssbindir=" #$output "/sbin"))
+ (string-append "--with-ssbindir=" #$output "/sbin")
+ "--with-cryptsetup")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-file-names
@@ -4965,15 +4966,16 @@ (define-public pam-mount
(native-inputs
(list perl pkg-config))
(inputs
- (list cryptsetup
- libhx
- libxml2
- linux-pam
- lvm2
- openssl
- pcre2
- `(,util-linux "lib")
- util-linux))
+ (append
+ (cons* cryptsetup eudev (libcryptsetup-propagated-inputs))
+ (list libhx
+ libxml2
+ linux-pam
+ lvm2
+ openssl
+ pcre2
+ `(,util-linux "lib")
+ util-linux)))
(home-page "https://inai.de/projects/pam_mount/")
(synopsis "PAM module to mount volumes for a user session")
(description
base-commit: 6ea75bb9bcc52521f0bb3f121799745fdc17f1c9
--
2.46.0